[package] 6in4: re-establish tunnel also if no credentials are used (static setup)
authorJo-Philipp Wich <jow@openwrt.org>
Sun, 20 Feb 2011 18:27:19 +0000 (18:27 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sun, 20 Feb 2011 18:27:19 +0000 (18:27 +0000)
SVN-Revision: 25627

package/6in4/Makefile
package/6in4/files/6in4.hotplug

index 905d7f810bfccaff6cc414d73ec4a3bc877e4daa..9a2cfe20d29296ff12c1fc1c558b4e6237480aba 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=6in4
-PKG_VERSION:=8
+PKG_VERSION:=9
 PKG_RELEASE:=1
 
 include $(INCLUDE_DIR)/package.mk
index 9499296d92c21cad53258a59b41f36f24faa5643..49667a815e1caa1a9aaf5b91b4eb8cbedb91880f 100644 (file)
@@ -29,11 +29,12 @@ if [ "$ACTION" = ifup ]; then
                        local password
                        config_get password "$cfg" password
 
+                       uci_set_state network "$cfg" ipaddr "$wanip"
+
                        [ -n "$tunnelid" ] && [ -n "$username" ] && [ -n "$password" ] && {
                                [ "${#password}" == 32 -a -z "${password//[a-f0-9]/}" ] || {
                                        password="$(echo -n "$password" | md5sum)"; password="${password%% *}"
                                }
-                               uci_set_state network "$cfg" ipaddr "$wanip"
 
                                (
                                        local url="http://ipv4.tunnelbroker.net/ipv4_end.php?ipv4b=AUTO&user_id=$username&pass=$password&tunnel_id=$tunnelid"
@@ -51,6 +52,9 @@ if [ "$ACTION" = ifup ]; then
                                                }
                                        done
                                )&
+                       } || {
+                               logger -t 6in4-update "Re-establishing tunnel due to change on $INTERFACE ($DEVICE)"
+                               ifup "$cfg" &
                        }
                }
        }