fix board name for nvram and switch packages on brcm-2.4 after [8653]
authorNicolas Thill <nico@openwrt.org>
Fri, 7 Sep 2007 12:54:24 +0000 (12:54 +0000)
committerNicolas Thill <nico@openwrt.org>
Fri, 7 Sep 2007 12:54:24 +0000 (12:54 +0000)
SVN-Revision: 8664

package/broadcom-diag/Makefile
package/switch/Makefile

index e0827b0fbc3b93cf6801ea3f6e1d91b613b6e5f6..45bce0a3e89e8fea0544c2bee58aa1fa3e782c0b 100644 (file)
@@ -26,7 +26,7 @@ define Build/Prepare
        $(CP) ./src/* $(PKG_BUILD_DIR)/
 endef
 
-ifeq ($(BOARD),brcm)
+ifeq ($(BOARD),brcm-2.4)
        BUILDFLAGS=-DBCMDRIVER -I$(LINUX_DIR)/arch/mips/bcm947xx/include $(if $(CONFIG_LINUX_2_4),-DLINUX_2_4)
 endif
 
index b7c6dc8362b5b3de1cf0230687448032ff23d107..cdf1f512932e16f947f66509acf2ab84d0c6574e 100644 (file)
@@ -34,12 +34,12 @@ define Build/Prepare
        $(CP) ./src/* $(PKG_BUILD_DIR)/
 endef
 
-ifeq ($(BOARD),brcm)
-BUILDFLAGS := -DBROADCOM -DBCMDRIVER -I$(LINUX_DIR)/arch/mips/bcm947xx/include
+ifeq ($(BOARD),brcm-2.4)
+  BUILDFLAGS := -DBROADCOM -DBCMDRIVER -I$(LINUX_DIR)/arch/mips/bcm947xx/include
 else
-ifeq ($(BOARD),brcm47xx)
-BUILDFLAGS := -DBROADCOM
-endif
+  ifeq ($(BOARD),brcm47xx)
+    BUILDFLAGS := -DBROADCOM
+  endif
 endif