[ramips] adds support for Edimax BR-6524N
authorJohn Crispin <john@openwrt.org>
Sun, 6 Jan 2013 11:11:42 +0000 (11:11 +0000)
committerJohn Crispin <john@openwrt.org>
Sun, 6 Jan 2013 11:11:42 +0000 (11:11 +0000)
fixes #12754

Signed-off-by: <rq@akl.lt>
SVN-Revision: 35020

12 files changed:
target/linux/ramips/base-files/etc/diag.sh
target/linux/ramips/base-files/etc/hotplug.d/firmware/10-rt2x00-eeprom
target/linux/ramips/base-files/etc/uci-defaults/leds
target/linux/ramips/base-files/etc/uci-defaults/network
target/linux/ramips/base-files/lib/ramips.sh
target/linux/ramips/files/arch/mips/include/asm/mach-ralink/machine.h
target/linux/ramips/files/arch/mips/ralink/rt288x/Kconfig
target/linux/ramips/files/arch/mips/ralink/rt288x/Makefile
target/linux/ramips/files/arch/mips/ralink/rt288x/mach-br6524n.c [new file with mode: 0644]
target/linux/ramips/image/Makefile
target/linux/ramips/rt288x/config-3.6
target/linux/ramips/rt288x/profiles/edimax.mk [new file with mode: 0644]

index af05aceded0f618190a9080cb9ff34b77957cb7c..d8b913fca3f71bed4867ebb7ce7a5d3dbd72f459 100755 (executable)
@@ -36,6 +36,9 @@ get_status_led() {
        argus-atp52b)
                status_led="argus-atp52b:green:run"
                ;;
+       br6524n)
+               status_led="edimax:blue:power"
+               ;;
        dir-300-b1 | dir-600-b1 | dir-600-b2 | dir-615-h1 | dir-615-d | dir-620-a1)
                status_led="d-link:green:status"
                ;;
index be6975c8094312ac24886b1f66e252b30d647471..6bd2c922c8ad67f6d9b34be3bb363b604f630bb5 100644 (file)
@@ -59,6 +59,7 @@ case "$FIRMWARE" in
        argus-atp52b | \
        bc2 | \
        broadway | \
+       br6524n | \
        carambola | \
        dir-615-h1 | \
        dir-620-a1 | \
index b4dcdd1947aa0613d5880bb1559923b01f1dea31..fa9c4f0ab4e7d982f8533858d1cd56930504217b 100755 (executable)
@@ -36,6 +36,9 @@ case $board in
                set_usb_led "red:diskmounted"
                set_wifi_led "red:wps_active"
                ;;
+       br6524n)
+               set_wifi_led "edimax:blue:wlan"
+               ;;
        dir-300-b1|\
        dir-600-b1|\
        dir-600-b2|\
index 598074bb1937268156b731ff4d37fe8dade6b28f..bbcdf6fde7a9060cb88c9eafa4940bcd254d1a50 100755 (executable)
@@ -84,6 +84,7 @@ ramips_setup_interfaces()
                ucidef_set_interfaces_lan_wan "eth0.1" "eth0.2"
                ;;
 
+       br6524n | \
        v11st-fe)
                ucidef_set_interfaces_lan_wan "eth0.1" "eth0.2"
                ucidef_add_switch "switch0" "1" "1"
index 0128717e3587b4993224009ded8d9ffaa1d61993..03b49e8f313bcfdad80cc2be9577a1efa4618bac 100755 (executable)
@@ -71,6 +71,9 @@ ramips_board_name() {
        *"Argus ATP-52B")
                name="argus-atp52b"
                ;;
+       *"BR6524N")
+               name="br6524n"
+               ;;
        *"Asus WL-330N")
                name="wl-330n"
                ;;
index 3a750df01d6f071972b176f606603b37036f7035..bc183ab6abb5373d6b86c359cb62b1969a414fa2 100644 (file)
@@ -15,6 +15,7 @@ enum ramips_mach_type {
        RAMIPS_MACH_GENERIC,
        /* RT2880 based machines */
        RAMIPS_MACH_F5D8235_V1,         /* Belkin F5D8235 v1 */
+       RAMIPS_MACH_BR6524N,            /* Edimax BR6524N */
        RAMIPS_MACH_RT_N15,             /* Asus RT-N15 */
        RAMIPS_MACH_V11ST_FE,           /* Ralink V11ST-FE */
        RAMIPS_MACH_WLI_TX4_AG300N,     /* Buffalo WLI-TX4-AG300N */
index 31dcc8132b4e38fa9c252cb6f9f50eec7c0043a6..739561c64067674a4997731754611464c7674c40 100644 (file)
@@ -6,6 +6,11 @@ config RT288X_MACH_F5D8235_V1
        bool "Belkin F5D8235 V1 board support"
        select RALINK_DEV_GPIO_LEDS
 
+config RT288X_MACH_BR6524N
+       bool "Edimax BR6524N support"
+       select RALINK_DEV_GPIO_BUTTONS
+       select RALINK_DEV_GPIO_LEDS
+
 config RT288X_MACH_RT_N15
        bool "Asus RT-N15 board support"
        select RALINK_DEV_GPIO_BUTTONS
index 473f85599822057a2c5d96b9cfe3bfb50a4bc765..eb60c5d10d409cd46e93e59d217ff1d5f305fef8 100644 (file)
@@ -14,6 +14,7 @@ obj-y := irq.o setup.o rt288x.o devices.o clock.o
 obj-$(CONFIG_EARLY_PRINTK)             += early_printk.o
 
 obj-$(CONFIG_RT288X_MACH_F5D8235_V1)   += mach-f5d8235-v1.o
+obj-$(CONFIG_RT288X_MACH_BR6524N)      += mach-br6524n.o
 obj-$(CONFIG_RT288X_MACH_RT_N15)       += mach-rt-n15.o
 obj-$(CONFIG_RT288X_MACH_V11ST_FE)     += mach-v11st-fe.o
 obj-$(CONFIG_RT288X_MACH_WLI_TX4_AG300N) += mach-wli-tx4-ag300n.o
diff --git a/target/linux/ramips/files/arch/mips/ralink/rt288x/mach-br6524n.c b/target/linux/ramips/files/arch/mips/ralink/rt288x/mach-br6524n.c
new file mode 100644 (file)
index 0000000..ff4746c
--- /dev/null
@@ -0,0 +1,74 @@
+/*
+ *  Edimax BR6524N board support
+ *
+ *  Copyright (C) 2012 Florian Fainelli <florian@openwrt.org>
+ *
+ *  This program is free software; you can redistribute it and/or modify it
+ *  under the terms of the GNU General Public License version 2 as published
+ *  by the Free Software Foundation.
+ */
+
+#include <linux/init.h>
+#include <linux/platform_device.h>
+#include <linux/ethtool.h>
+
+#include <asm/mach-ralink/machine.h>
+#include <asm/mach-ralink/dev-gpio-buttons.h>
+#include <asm/mach-ralink/dev-gpio-leds.h>
+#include <asm/mach-ralink/rt288x.h>
+#include <asm/mach-ralink/rt288x_regs.h>
+#include <asm/mach-ralink/ramips_eth_platform.h>
+
+#include "devices.h"
+
+#define BR6524N_GPIO_STATUS_LED        12
+#define BR6524N_GPIO_BUTTON_WPS        0
+
+#define BR6524N_KEYS_POLL_INTERVAL     20
+#define BR6524N_KEYS_DEBOUNCE_INTERVAL (3 * BR6524N_KEYS_POLL_INTERVAL)
+
+static struct gpio_led br6524n_leds_gpio[] __initdata = {
+       {
+               .name           = "br6524n:green:status",
+               .gpio           = BR6524N_GPIO_STATUS_LED,
+               .active_low     = 1,
+       }
+};
+
+static struct gpio_keys_button br6524n_gpio_buttons[] __initdata = {
+       {
+               .desc           = "wps",
+               .type           = EV_KEY,
+               .code           = KEY_WPS_BUTTON,
+               .debounce_interval = BR6524N_KEYS_DEBOUNCE_INTERVAL,
+               .gpio           = BR6524N_GPIO_BUTTON_WPS,
+       }
+};
+
+static void __init br6524n_fe_init(void)
+{
+       rt288x_gpio_init(RT2880_GPIO_MODE_UART0);
+
+       rt288x_register_flash(0);
+
+       ramips_register_gpio_leds(-1, ARRAY_SIZE(br6524n_leds_gpio),
+                                 br6524n_leds_gpio);
+
+       ramips_register_gpio_buttons(-1, BR6524N_KEYS_POLL_INTERVAL,
+                                    ARRAY_SIZE(br6524n_gpio_buttons),
+                                    br6524n_gpio_buttons);
+
+       rt288x_register_wifi();
+
+       /* Board is connected to an IC+ IP175C Fast Ethernet switch */
+       rt288x_eth_data.speed = SPEED_100;
+       rt288x_eth_data.duplex = DUPLEX_FULL;
+       rt288x_eth_data.tx_fc = 1;
+       rt288x_eth_data.rx_fc = 1;
+       rt288x_eth_data.phy_mask = BIT(0);
+       rt288x_register_ethernet();
+
+       rt288x_register_wdt();
+}
+
+MIPS_MACHINE(RAMIPS_MACH_BR6524N, "BR6524N", "Edimax BR6524N", br6524n_fe_init);
index 631be1d1a62d0055c6946833418482e1a3993fe9..27ac10b98171e0abe0aa6684c53c29cfb09c0bc3 100644 (file)
@@ -259,6 +259,11 @@ define BuildFirmware/Edimax
        fi
 endef
 
+define BuildFirmware/BR6524N
+       $(call BuildFirmware/Generic,$(1),$(2),$(call mkcmdline,$(3),$(4),$(5)) $(call mkmtd/$(6),$(mtdlayout_4M)),917484,2949120)
+       $(call BuildFirmware/Edimax,$(1),br6524n,CSYS,WNRA,0x50000,0xc00000)
+endef
+
 mtdlayout_f5d8235=320k(u-boot)ro,1536k(kernel),6208k(rootfs),64k(nvram),64k(factory),7744k@0x50000(firmware)
 mtd_f5d8235_kernel_part_size=1572864
 mtd_f5d8235_rootfs_part_size=6356992
@@ -443,6 +448,10 @@ define Image/Build/Profile/F5D8235V1
        $(call Image/Build/Template/$(fs_squash)/$(1),F5D8235,f5d8235v1,F5D8235_V1)
 endef
 
+define Image/Build/Profile/BR6524N
+       $(call Image/Build/Template/$(fs_squash)/$(1),BR6524N,br6524n,BR6524N,ttyS1,57600,phys)
+endef
+
 define Image/Build/Profile/RTN15
        $(call Image/Build/Template/$(fs_squash)/$(1),GENERIC_4M,rt-n15,RT-N15,ttyS1,57600,phys)
 endef
@@ -458,6 +467,7 @@ endef
 ifeq ($(CONFIG_RALINK_RT288X),y)
 define Image/Build/Profile/Default
        $(call Image/Build/Profile/F5D8235V1,$(1))
+       $(call Image/Build/Profile/BR6524N,$(1))
        $(call Image/Build/Profile/RTN15,$(1))
        $(call Image/Build/Profile/V11STFE,$(1))
        $(call Image/Build/Profile/WLITX4AG300N,$(1))
index eefe11eb1219ee0ff9310b4f4946d87fa5e7b5c4..e2a7c3c3a3cc4e2576a44d592ddbf0ca9059dc9e 100644 (file)
@@ -97,6 +97,7 @@ CONFIG_RALINK_RT288X=y
 CONFIG_RAMIPS_WDT=y
 CONFIG_RT288X_MACH_F5D8235_V1=y
 CONFIG_RT288X_MACH_RT_N15=y
+CONFIG_RT288X_MACH_BR6524N=y
 CONFIG_RT288X_MACH_V11ST_FE=y
 CONFIG_RT288X_MACH_WLI_TX4_AG300N=y
 CONFIG_RT288X_MACH_WZR_AGL300NH=y
diff --git a/target/linux/ramips/rt288x/profiles/edimax.mk b/target/linux/ramips/rt288x/profiles/edimax.mk
new file mode 100644 (file)
index 0000000..43ac818
--- /dev/null
@@ -0,0 +1,18 @@
+#
+# Copyright (C) 2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/BR6524N
+       NAME:=Edimax BR6524N
+       PACKAGES:=kmod-switch-ip17xx kmod-swconfig swconfig
+endef
+
+define Profile/BR6524N/Description
+       Package set for Edimax BR6524N
+endef
+
+$(eval $(call Profile,BR6524N))
+