[package] ppp: synthesize a .device option to make ifup work on pppoa interfaces...
authorJo-Philipp Wich <jow@openwrt.org>
Mon, 17 Jan 2011 00:14:18 +0000 (00:14 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Mon, 17 Jan 2011 00:14:18 +0000 (00:14 +0000)
SVN-Revision: 25025

package/ppp/Makefile
package/ppp/files/pppoa.sh

index eae32d0439a56c9ff7f8b883371c7f06ce9f096a..5be8e7cce5db77ba13230a5fe281f8360775cf1d 100644 (file)
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=ppp
 PKG_VERSION:=2.4.4
-PKG_RELEASE:=13
+PKG_RELEASE:=14
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=ftp://ftp.samba.org/pub/ppp/
index df947aa83d3a4ecb654f20c0b7af007a8dab8da2..c64e809de389b6dad17b9f0dbad98b99dbfb5d51 100644 (file)
@@ -1,3 +1,7 @@
+scan_pppoa() {
+       config_set "$1" device "pppoa-$1"
+}
+
 coldplug_interface_pppoa() {
        setup_interface_pppoa x "$1"
 }