[package] update dansguardian to 2.10.1.1 (#5539)
authorFlorian Fainelli <florian@openwrt.org>
Fri, 17 Jul 2009 11:17:53 +0000 (11:17 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Fri, 17 Jul 2009 11:17:53 +0000 (11:17 +0000)
SVN-Revision: 16874

net/dansguardian/Makefile
net/dansguardian/patches/001-include_dir.patch
net/dansguardian/patches/002-2.10-uclibc++.patch

index 3827e3005027d2419b4612253a9251f144700159..3c320102ac2df114c920737c59198dc02398287e 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dansguardian
-PKG_VERSION:=2.10.0.2
+PKG_VERSION:=2.10.1.1
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://dansguardian.org/downloads/2/Stable
-PKG_MD5SUM:=0a6c6d35c9e0c82fbc4a2150e8ffe977
+PKG_MD5SUM:=0987a1c9bfbdf398118386f10279611a
 
 include $(INCLUDE_DIR)/package.mk
 
index e575feba4f773b24dd601898299e205418faee2b..8a619f08a59d5fcb0a6f9103c7748c999cd42375 100644 (file)
@@ -1,8 +1,6 @@
-Index: dansguardian-2.9.9.2/configure
-===================================================================
---- dansguardian-2.9.9.2.orig/configure        2008-02-27 17:52:06.000000000 +0100
-+++ dansguardian-2.9.9.2/configure     2008-02-27 17:52:06.000000000 +0100
-@@ -799,7 +799,7 @@
+--- a/configure
++++ b/configure
+@@ -861,7 +861,7 @@ sysconfdir='${prefix}/etc'
  sharedstatedir='${prefix}/com'
  localstatedir='${prefix}/var'
  includedir='${prefix}/include'
@@ -11,7 +9,7 @@ Index: dansguardian-2.9.9.2/configure
  docdir='${datarootdir}/doc/${PACKAGE_TARNAME}'
  infodir='${datarootdir}/info'
  htmldir='${docdir}'
-@@ -6429,7 +6429,7 @@
+@@ -6317,7 +6317,7 @@ $as_echo_n "checking for zlib... " >&6; 
  # Check whether --with-zlib was given.
  if test "${with_zlib+set}" = set; then
    withval=$with_zlib;  # check for header & func (in library) in given prefix
@@ -20,7 +18,7 @@ Index: dansguardian-2.9.9.2/configure
        if test "x$staticzlib" = "xtrue"; then
                LIBS="-Bstatic -L${withval} -lz -Bdynamic ${LIBS}"
        else
-@@ -10753,7 +10753,7 @@
+@@ -10042,7 +10042,7 @@ _ACEOF
  if test "${with_libiconv+set}" = set; then
    withval=$with_libiconv;  # check for header & func (in library) in given prefix
                        if test "x$withval" != "x"; then
index 27b4177172aaaf563f4f53f837978fc6a7a52579..e69de29bb2d1d6434b8b29ae775ad8c2e48c5391 100644 (file)
@@ -1,11 +0,0 @@
---- dansguardian-2.10/src/IPList.cpp.orig      2008-11-19 07:45:54 +0000
-+++ dansguardian-2.10/src/IPList.cpp   2008-11-19 07:46:44 +0000
-@@ -81,7 +81,7 @@
-                       hostnames.reset(new std::deque<String>);
-                       hostnames->push_back(*host);
-               }
--              for (std::deque<String>::const_iterator i = hostnames->begin(); i != hostnames->end(); ++i) 
-+              for (std::deque<String>::iterator i = hostnames->begin(); i != hostnames->end(); ++i) 
-               {
-                       if (std::binary_search(hostlist.begin(), hostlist.end(), *i))
-                       {