binutils: remove the empty package libbfd and fix all references to it
authorFelix Fietkau <nbd@openwrt.org>
Wed, 2 Sep 2009 22:39:26 +0000 (22:39 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Wed, 2 Sep 2009 22:39:26 +0000 (22:39 +0000)
SVN-Revision: 17481

devel/binutils/Makefile
devel/ksymoops/Makefile
devel/oprofile/Makefile

index 16b39bcf684248238502e1f91085a89ff2070489..318d387831b3b6837f04d0f09876771437effa81 100644 (file)
@@ -35,12 +35,6 @@ define Package/binutils/description
   The Binutils package contains a linker, an assembler, and other tools for handling object files
 endef
 
-define Package/libbfd
-  SECTION:=libs
-  CATEGORY:=Libraries
-  TITLE:=libbfd
-endef
-
 TARGET_CFLAGS += $(FPIC)
 
 define Build/Configure
@@ -80,10 +74,5 @@ define Package/binutils/install
        rm -f $(1)/usr/bin/objdump
 endef
 
-define Package/libbfd/install
-    true
-endef
-
 $(eval $(call BuildPackage,binutils))
 $(eval $(call BuildPackage,objdump))
-$(eval $(call BuildPackage,libbfd))
index a92d3f445aaedac0237c50dd4a2c2a2ec4b93e19..31ac06311fe68cb6764420805468bd213440d931 100644 (file)
@@ -16,12 +16,14 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@KERNEL/linux/utils/kernel/ksymoops/v2.4/
 PKG_MD5SUM:=4a8249e182a5dbc75e566d162e9f3314
 
+PKG_BUILD_DEPENDS:=binutils
+
 include $(INCLUDE_DIR)/package.mk
 
 define Package/ksymoops
   SECTION:=utils
   CATEGORY:=Utilities
-  DEPENDS:=@LINUX_2_6 @mips||mipsel||m68k||i386 +libbfd
+  DEPENDS:=@LINUX_2_6 @mips||mipsel||m68k||i386
   TITLE:=Interpret oops of the kernel
   URL:=http://www.kernel.org/pub/linux/utils/kernel/ksymoops/v2.4/
   MENU:=1
index 3105f7fe3efbde0c6c2c78cfbec3ba7354482364..a4efd8b7547eed1f609111b223ee4112151cb5e6 100644 (file)
@@ -15,7 +15,7 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/oprofile/
 PKG_MD5SUM:=82b059379895cf125261d7d773465915
 PKG_INSTALL:=1
-PKG_BUILD_DEPENDS:=libbfd
+PKG_BUILD_DEPENDS:=binutils
 
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/kernel.mk