ixp4xx: don't leave zImage on the rootfs for images other than the freecom one
authorFelix Fietkau <nbd@openwrt.org>
Mon, 6 Apr 2009 10:29:40 +0000 (10:29 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Mon, 6 Apr 2009 10:29:40 +0000 (10:29 +0000)
SVN-Revision: 15117

target/linux/ixp4xx/image/Makefile

index 82f2e96d587c0c5baae5fc18368ff04e3813f769..b1c715a640073d5f56c524c210d2510c5b5554c7 100644 (file)
@@ -30,6 +30,7 @@ define Image/Build/Freecom
        $(INSTALL_DIR) $(TARGET_DIR)/var
        $(TAR) cfj $(BIN_DIR)/openwrt-$(2)-$(1).img --numeric-owner --owner=0 --group=0 -C $(TARGET_DIR)/ .
        $(STAGING_DIR_HOST)/bin/encode_crc $(BIN_DIR)/openwrt-$(2)-$(1).img $(BIN_DIR)/openwrt-$(2)-$(1)-webupgrade.img
+       rm -f $(TARGET_DIR)/zImage
 endef
 
 define Image/Prepare