revert find | xargs => find | exec changes - this is completely unnecessary and intro...
authorFelix Fietkau <nbd@openwrt.org>
Thu, 12 Apr 2007 19:18:38 +0000 (19:18 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Thu, 12 Apr 2007 19:18:38 +0000 (19:18 +0000)
SVN-Revision: 6942

Makefile
include/image.mk
include/package-ipkg.mk
include/prereq-build.mk
scripts/feeds.sh
target/imagebuilder/Makefile
target/sdk/Makefile

index 2a5180c61bf07a27bf63249caaf76a320f317188..6b30ef92fa31f460d2b8862b1777cda40efc0bce 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -155,7 +155,7 @@ docclean:
        $(MAKE) -C docs/ clean
 
 symlinkclean:
-       find package -type l -exec rm -f {} +
+       find package -type l | xargs -r rm -f
 
 .SILENT: clean dirclean distclean symlinkclean config-clean download world help tmp/.packageinfo tmp/.targetinfo tmpinfo-clean tmp/.config-package.in tmp/.config-target.in .config scripts/config/mconf scripts/config/conf menuconfig tmp/.prereq-build tmp/.prereq-package tmp/.prereq-target
 FORCE: ;
index eb59ea651cd84e3fdc7f31f42a84f4375dcfe153..0e6a7cdbeab280b9615b210d0c4313f042e802ed 100644 (file)
@@ -79,9 +79,9 @@ endif
 
 
 define Image/mkfs/prepare/default
-       find $(BUILD_DIR)/root -type f -not -perm +0100 -not -name 'ssh_host*' -exec chmod 0644 {} \;
-       find $(BUILD_DIR)/root -type f -perm +0100 -exec chmod 0755 {} \;
-       find $(BUILD_DIR)/root -type d -exec chmod 0755 {} \;
+       find $(BUILD_DIR)/root -type f -not -perm +0100 -not -name 'ssh_host*' | xargs -r chmod 0644
+       find $(BUILD_DIR)/root -type f -perm +0100 | xargs -r chmod 0755
+       find $(BUILD_DIR)/root -type d | xargs -r chmod 0755
        mkdir -p $(BUILD_DIR)/root/tmp
        chmod 0777 $(BUILD_DIR)/root/tmp
 endef
index 8b317065bfd4bf04ab20ac051f4c6e2fb53e72a3..86c802289c34d38556a6360243657cac18ca5043 100644 (file)
@@ -71,9 +71,9 @@ ifeq ($(DUMP),)
     $$(IPKG_$(1)): $(PKG_BUILD_DIR)/.built $$(IDIR_$(1))/CONTROL/control
        $(call Package/$(1)/install,$$(IDIR_$(1)))
        mkdir -p $(PACKAGE_DIR)
-       -find $$(IDIR_$(1)) -name CVS   -exec rm -rf {} +
-       -find $$(IDIR_$(1)) -name .svn  -exec rm -rf {} +
-       -find $$(IDIR_$(1)) -name '.#*' -exec rm -f  {} +
+       -find $$(IDIR_$(1)) -name CVS   | xargs -r rm -rf
+       -find $$(IDIR_$(1)) -name .svn  | xargs -r rm -rf
+       -find $$(IDIR_$(1)) -name '.#*' | xargs -r rm -f
        $(RSTRIP) $$(IDIR_$(1))
        $(IPKG_BUILD) $$(IDIR_$(1)) $(PACKAGE_DIR)
        @[ -f $$(IPKG_$(1)) ] || false 
index 7355b9e31c1e3c8cad24fd54897159717c3d8555..d3aec643999c81501b5adc8f73d7189097dfc6ac 100644 (file)
@@ -121,11 +121,3 @@ $(eval $(call Require,gnutar, \
 $(eval $(call RequireCommand,autoconf, \
        Please install GNU autoconf. \
 ))
-
-define Require/find
-       find . -maxdepth 1 -exec ls {} + > /dev/null 2>&1
-endef
-
-$(eval $(call Require,find, \
-       Please install GNU find 4.2.12 or better. \
-))
index 9fc3343a1be14a51a8e5587e920110f46afc923b..a6d4ef9d71a713513e12fe66800e438366c0da28 100755 (executable)
@@ -22,7 +22,7 @@ cd $TOPDIR
 
 # Some functions we might call several times a run
 delete_symlinks() {
-       find $1 -type l -exec rm -f {} +
+       find $1 -type l | xargs -r rm -f
 }
 
 setup_symlinks() {
index cf4a6fe1a108347d94925fa460d468e205788d51..5d0a87b28b27deec2331155cf04198fe705e7c79 100644 (file)
@@ -33,8 +33,8 @@ $(BIN_DIR)/$(IB_NAME).tar.bz2: clean
        $(CP) $(TOPDIR)/target/linux/* $(IB_BUILD_DIR)/target/linux
        rm -rf $(IB_BUILD_DIR)/target/linux/*/patches
        -cp $(BUILD_DIR)/linux-$(KERNEL)-$(BOARD)/* $(IB_BUILD_DIR)/build_$(ARCH)/linux-$(KERNEL)-$(BOARD) # don't copy subdirectories here
-       find $(IB_BUILD_DIR) -name .svn -exec rm -rf {} +
-       find $(IB_BUILD_DIR) -name CVS -exec rm -rf  {} +
+       find $(IB_BUILD_DIR) -name .svn | xargs rm -rf
+       find $(IB_BUILD_DIR) -name CVS | xargs rm -rf
        (cd $(BUILD_DIR); \
                tar cfj $@ $(IB_NAME); \
        )
index c0fc027cb488850f77ae848719c5d33ff08098d4..9f12631863c583ee1444dd1be349973f8f87c7ed 100644 (file)
@@ -35,8 +35,8 @@ $(BIN_DIR)/$(SDK_NAME).tar.bz2: clean
        $(CP) ./files/package/rules.mk $(SDK_BUILD_DIR)/package/
        echo OPENWRTVERSION:=$(OPENWRTVERSION) > $(SDK_BUILD_DIR)/.version.mk
        rm -rf $(SDK_BUILD_DIR)/staging_dir*/ccache
-       find $(SDK_BUILD_DIR) -name .svn -exec rm -rf {} + 
-       find $(SDK_BUILD_DIR) -name CVS -exec rm -rf  {} +
+       find $(SDK_BUILD_DIR) -name .svn | xargs -r rm -rf
+       find $(SDK_BUILD_DIR) -name CVS | xargs -r rm -rf
        (cd $(BUILD_DIR); \
                tar cfj $@ $(SDK_NAME); \
        )