[backfire] refresh generic 2.6.30 patches
authorJo-Philipp Wich <jow@openwrt.org>
Fri, 29 Oct 2010 19:31:47 +0000 (19:31 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Fri, 29 Oct 2010 19:31:47 +0000 (19:31 +0000)
SVN-Revision: 23714

target/linux/generic-2.6/patches-2.6.30/014-cfi_fix_amd_extended_table_check.patch
target/linux/generic-2.6/patches-2.6.30/930-kmsg_dump_backport.patch
target/linux/generic-2.6/patches-2.6.30/931-crashlog.patch

index 1216a3bd3e6c59abe3c6f12f95ec4b521bef7c7b..3c7d303b7a473e02d28769a0085dced3eca087cd 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/mtd/chips/cfi_cmdset_0002.c
 +++ b/drivers/mtd/chips/cfi_cmdset_0002.c
-@@ -336,6 +336,8 @@ static struct cfi_fixup fixup_table[] =
+@@ -336,6 +336,8 @@ static struct cfi_fixup fixup_table[] = 
  static void cfi_fixup_major_minor(struct cfi_private *cfi,
                                  struct cfi_pri_amdstd *extp)
  {
@@ -9,7 +9,7 @@
        if (cfi->mfr == CFI_MFR_SAMSUNG && cfi->id == 0x257e &&
            extp->MajorVersion == '0')
                extp->MajorVersion = '1';
-@@ -366,6 +368,9 @@ struct mtd_info *cfi_cmdset_0002(struct
+@@ -366,6 +368,9 @@ struct mtd_info *cfi_cmdset_0002(struct 
        mtd->name    = map->name;
        mtd->writesize = 1;
  
@@ -19,7 +19,7 @@
        if (cfi->cfi_mode==CFI_MODE_CFI){
                unsigned char bootloc;
                /*
-@@ -384,16 +389,24 @@ struct mtd_info *cfi_cmdset_0002(struct
+@@ -384,16 +389,24 @@ struct mtd_info *cfi_cmdset_0002(struct 
  
                cfi_fixup_major_minor(cfi, extp);
  
index 762b441114a595b36170eacff95491aa24567889..cdcf094d0cfda970e0ea0949642e32e28b9e6215 100644 (file)
@@ -55,7 +55,7 @@
  #include <linux/kallsyms.h>
  #include <linux/notifier.h>
  #include <linux/module.h>
-@@ -74,6 +75,7 @@
+@@ -74,6 +75,7 @@ NORET_TYPE void panic(const char * fmt, 
        dump_stack();
  #endif
  
@@ -63,7 +63,7 @@
        /*
         * If we have crashed and we have a crash kernel loaded let it handle
         * everything else.
-@@ -337,6 +339,7 @@
+@@ -337,6 +339,7 @@ void oops_exit(void)
  {
        do_oops_enter_exit();
        print_oops_end_marker();
@@ -81,7 +81,7 @@
  
  #include <asm/uaccess.h>
  
-@@ -1322,3 +1323,121 @@
+@@ -1322,3 +1323,121 @@ bool printk_timed_ratelimit(unsigned lon
  }
  EXPORT_SYMBOL(printk_timed_ratelimit);
  #endif
index d4424190c69993648c76efc298c5109efaa4c293..4c7ba2390a5c9dc6f47c143bd7b402a43747b2d8 100644 (file)
@@ -1,6 +1,6 @@
 --- a/init/Kconfig
 +++ b/init/Kconfig
-@@ -723,6 +723,9 @@
+@@ -723,6 +723,9 @@ config NET_NS
          Allow user space to create what appear to be multiple instances
          of the network stack.
  
@@ -12,7 +12,7 @@
        depends on BROKEN || !FRV
 --- a/kernel/Makefile
 +++ b/kernel/Makefile
-@@ -95,6 +95,7 @@
+@@ -95,6 +95,7 @@ obj-$(CONFIG_FUNCTION_TRACER) += trace/
  obj-$(CONFIG_TRACING) += trace/
  obj-$(CONFIG_SMP) += sched_cpupri.o
  obj-$(CONFIG_SLOW_WORK) += slow-work.o
@@ -30,7 +30,7 @@
  
  #include <asm/bug.h>
  #include <asm/io.h>
-@@ -151,6 +152,7 @@
+@@ -151,6 +152,7 @@ static unsigned long __init free_all_boo
        if (!bdata->node_bootmem_map)
                return 0;