New package jsonpath
authorJohn Crispin <john@openwrt.org>
Sun, 3 Jul 2011 19:19:53 +0000 (19:19 +0000)
committerJohn Crispin <john@openwrt.org>
Sun, 3 Jul 2011 19:19:53 +0000 (19:19 +0000)
This patch adds a new python package called jsonpath.

JSONPath allows you to run XPATH-like queries over json data structures.

Changes since v1:
* removed unrelated changes
* fix copyright

Signed-off-by: Roberto Riggio <roberto.riggio@create-net.org>
SVN-Revision: 27415

lang/jsonpath/Makefile [new file with mode: 0644]

diff --git a/lang/jsonpath/Makefile b/lang/jsonpath/Makefile
new file mode 100644 (file)
index 0000000..25cb124
--- /dev/null
@@ -0,0 +1,46 @@
+#
+# Copyright (C) 2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=jsonpath
+PKG_VERSION:=0.52.1
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://www.ultimate.com/phil/python/download/
+PKG_MD5SUM:=4cd0c3a70acbc67d2915d64f132cdb4f
+PKG_BUILD_DEPENDS:=python
+
+include $(INCLUDE_DIR)/package.mk
+$(call include_mk, python-package.mk)
+
+define Package/jsonpath
+  SUBMENU:=Python
+  SECTION:=lang
+  CATEGORY:=Languages
+  TITLE:=JsonPath - XPath implementation
+  URL:=http://goessner.net/articles/JsonPath/
+  DEPENDS:=+python
+endef
+
+define Package/jsonpath/description
+  An XPath implementation for JSON
+endef
+
+define Build/Compile
+       $(call Build/Compile/PyMod,,install --prefix="$(PKG_INSTALL_DIR)/usr")
+endef
+
+define Package/jsonpath/install
+       $(INSTALL_DIR) $(1)$(PYTHON_PKG_DIR)
+       $(CP) \
+           $(PKG_INSTALL_DIR)$(PYTHON_PKG_DIR)/* \
+           $(1)$(PYTHON_PKG_DIR)
+endef
+
+$(eval $(call BuildPackage,jsonpath))