packages/mrd6: use new service functions, add a dependency on kmod-ipv6
authorNicolas Thill <nico@openwrt.org>
Wed, 9 Nov 2011 23:49:19 +0000 (23:49 +0000)
committerNicolas Thill <nico@openwrt.org>
Wed, 9 Nov 2011 23:49:19 +0000 (23:49 +0000)
SVN-Revision: 28925

ipv6/mrd6/Makefile
ipv6/mrd6/files/mrd6.init

index d71ed345f3fc23d83ff4fd745bb8b4d3eb247df9..dc99a2100b68c9655e84f668579f5d452e25657c 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mrd6
 PKG_VERSION:=0.9.6
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 
 PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).orig.tar.gz
 PKG_SOURCE_URL:=http://ftp.de.debian.org/debian/pool/main/m/mrd6/
@@ -25,7 +25,7 @@ define Package/mrd6
   CATEGORY:=IPv6
   TITLE:=IPv6 multicast routing daemon
   URL:=http://fivebits.net/proj/mrd6
-  DEPENDS:=+libstdcpp
+  DEPENDS:=+kmod-ipv6 +libstdcpp
 endef
 
 define Package/mrd6/description
index 70b88fb8e03965d8fdb3bfecc693843a503b254d..24818407f4cbabc321b0ad42eac61b8faa01dac4 100644 (file)
@@ -1,22 +1,13 @@
 #!/bin/sh /etc/rc.common
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
+
 START=50
 
 start() {
-       /sbin/lsmod | grep ipv6 > /dev/null
-       if [ "$?" != "0" ]; then
-               echo -n "IPv6 stack required by mrd6. Loading ipv6 module: "
-               /sbin/insmod ipv6
-               echo "Done."
-       fi
-       echo -n "Starting IPv6 multicast router (mrd6): "
-       /usr/sbin/mrd6 -f /etc/mrd6.conf -D
-       echo "Done."
+       service_start /usr/sbin/mrd6 -f /etc/mrd6.conf -D
 }
 
 stop() {
-       echo -n "Stopping IPv6 multicast router (mrd6): "
-       killall mrd6
-       echo "Done."
+       service_stop /usr/sbin/mrd6
 }