[x86] move i2c modules back to target modules.mk
authorFlorian Fainelli <florian@openwrt.org>
Wed, 25 Jul 2012 15:49:54 +0000 (15:49 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Wed, 25 Jul 2012 15:49:54 +0000 (15:49 +0000)
SVN-Revision: 32850

package/kernel/modules/i2c.mk
target/linux/x86/modules.mk

index 50501cf4ba5c28be945729e7f184158dddaf2ac6..0eb8a07a81801e9b9b724c6880c7bb1e92b34529 100644 (file)
@@ -101,41 +101,6 @@ endef
 
 $(eval $(call KernelPackage,i2c-gpio))
 
 
 $(eval $(call KernelPackage,i2c-gpio))
 
-I2C_SCX200_MODULES:=\
-  CONFIG_SCx200_I2C:drivers/i2c/busses/scx200_i2c
-
-define KernelPackage/i2c-scx200
-  $(call i2c_defaults,$(I2C_SCX200_MODULES),59)
-  TITLE:=Geode SCx200 I2C using GPIO pins
-  DEPENDS:=@PCI_SUPPORT @TARGET_x86 +kmod-i2c-algo-bit
-  KCONFIG+= \
-       CONFIG_SCx200_I2C_SCL=12 \
-       CONFIG_SCx200_I2C_SDA=13
-endef
-
-define KernelPackage/i2c-scx200/description
- Kernel module for I2C using GPIO pins on the Geode SCx200 processors.
-endef
-
-$(eval $(call KernelPackage,i2c-scx200))
-
-
-I2C_SCX200_ACB_MODULES:=\
-  CONFIG_SCx200_ACB:drivers/i2c/busses/scx200_acb
-
-define KernelPackage/i2c-scx200-acb
-  $(call i2c_defaults,$(I2C_SCX200_ACB_MODULES),59)
-  TITLE:=Geode SCx200 ACCESS.bus support
-  DEPENDS:=@PCI_SUPPORT @TARGET_x86 +kmod-i2c-algo-bit
-endef
-
-define KernelPackage/i2c-scx200-acb/description
- Kernel module for I2C using the ACCESS.bus controllers on the Geode SCx200
- and SC1100 processors and the CS5535 and CS5536 Geode companion devices.
-endef
-
-$(eval $(call KernelPackage,i2c-scx200-acb))
-
 
 OF_I2C_MODULES:=\
   CONFIG_OF_I2C:drivers/of/of_i2c
 
 OF_I2C_MODULES:=\
   CONFIG_OF_I2C:drivers/of/of_i2c
index 2942b3a5f688f8ec27c13c3db5f2811e8822a8b9..7826dc8acd55b5262b6edc1723052ada3334e65c 100644 (file)
@@ -246,3 +246,37 @@ endef
 
 $(eval $(call KernelPackage,wdt-scx200))
 
 
 $(eval $(call KernelPackage,wdt-scx200))
 
+I2C_SCX200_MODULES:=\
+  CONFIG_SCx200_I2C:drivers/i2c/busses/scx200_i2c
+
+define KernelPackage/i2c-scx200
+  $(call i2c_defaults,$(I2C_SCX200_MODULES),59)
+  TITLE:=Geode SCx200 I2C using GPIO pins
+  DEPENDS:=@PCI_SUPPORT @TARGET_x86 +kmod-i2c-algo-bit
+  KCONFIG+= \
+       CONFIG_SCx200_I2C_SCL=12 \
+       CONFIG_SCx200_I2C_SDA=13
+endef
+
+define KernelPackage/i2c-scx200/description
+ Kernel module for I2C using GPIO pins on the Geode SCx200 processors.
+endef
+
+$(eval $(call KernelPackage,i2c-scx200))
+
+
+I2C_SCX200_ACB_MODULES:=\
+  CONFIG_SCx200_ACB:drivers/i2c/busses/scx200_acb
+
+define KernelPackage/i2c-scx200-acb
+  $(call i2c_defaults,$(I2C_SCX200_ACB_MODULES),59)
+  TITLE:=Geode SCx200 ACCESS.bus support
+  DEPENDS:=@PCI_SUPPORT @TARGET_x86 +kmod-i2c-algo-bit
+endef
+
+define KernelPackage/i2c-scx200-acb/description
+ Kernel module for I2C using the ACCESS.bus controllers on the Geode SCx200
+ and SC1100 processors and the CS5535 and CS5536 Geode companion devices.
+endef
+
+$(eval $(call KernelPackage,i2c-scx200-acb))