ar71xx: Add TP-Link TL-WA901ND v4 support to Chaos Calmer 15.05.1
authorJohn Crispin <john@openwrt.org>
Mon, 25 Apr 2016 20:08:49 +0000 (20:08 +0000)
committerJohn Crispin <john@openwrt.org>
Mon, 25 Apr 2016 20:08:49 +0000 (20:08 +0000)
This patch backports support for the TP-Link TL-WA901ND v4 to Chaos Calmer 15.05.1,
which was added into trunk recently [1].

Signed-off by Stijn Segers <francesco.borromini@inventati.org>

[1]: http://patchwork.ozlabs.org/patch/606780/

SVN-Revision: 49226

target/linux/ar71xx/base-files/etc/diag.sh
target/linux/ar71xx/base-files/etc/uci-defaults/01_leds
target/linux/ar71xx/base-files/etc/uci-defaults/02_network
target/linux/ar71xx/base-files/lib/ar71xx.sh
target/linux/ar71xx/base-files/lib/upgrade/platform.sh
target/linux/ar71xx/config-3.18
target/linux/ar71xx/files/arch/mips/ath79/mach-tl-wa901nd-v4.c [new file with mode: 0644]
target/linux/ar71xx/image/Makefile
target/linux/ar71xx/patches-3.18/907-MIPS-ath79-add-tl-wa901nd-v4-support.patch [new file with mode: 0644]
tools/firmware-utils/src/mktplinkfw.c

index 3e80c32181b7e1539e775ab29ce69db6830f562a..6f2bd1c290d82ea1a2c85f97c6e0ef686ac2aecf 100644 (file)
@@ -255,6 +255,7 @@ get_status_led() {
        tl-wa901nd | \
        tl-wa901nd-v2 | \
        tl-wa901nd-v3 | \
+       tl-wa901nd-v4 | \
        tl-wdr3500 | \
        tl-wr1041n-v2 | \
        tl-wr1043nd | \
index 11b3fa09d0f621f49445484fef5359a00f0eea15..142950c252e2bb56e0bf2911afad0b6ddfa4a76b 100644 (file)
@@ -407,6 +407,11 @@ tl-wa901nd-v2)
        ucidef_set_led_wlan "wlan" "WLAN" "tp-link:green:wlan" "phy0tpt"
        ;;
 
+tl-wa901nd-v4)
+       ucidef_set_led_netdev "lan" "LAN" "tp-link:green:lan" "eth0"
+       ucidef_set_led_wlan "wlan" "WLAN" "tp-link:green:wlan" "phy0tpt"
+       ;;
+
 tl-wdr3500)
        ucidef_set_led_usbdev "usb" "USB" "tp-link:green:usb" "1-1"
        ucidef_set_led_wlan "wlan2g" "WLAN2G" "tp-link:green:wlan2g" "phy0tpt"
index c0becfecb97c7865d80f12a6f3cf00fd1a0a8ab0..29d60da02e5e6912f3c8ba269ba04a3f1751ef2f 100755 (executable)
@@ -362,6 +362,7 @@ tl-wa801nd-v2 |\
 tl-wa901nd |\
 tl-wa901nd-v2 |\
 tl-wa901nd-v3 |\
+tl-wa901nd-v4 |\
 tl-wr703n |\
 tube2h |\
 wndap360 |\
index 5768286b68fcce78a4285c253699a561dabbd7f6..6dc975dd00e6852e8eb8fffbc5ab97ad030a5a18 100755 (executable)
@@ -767,6 +767,9 @@ ar71xx_board_detect() {
        *"TL-WA901ND v3")
                name="tl-wa901nd-v3"
                ;;
+       *"TL-WA901ND v4")
+               name="tl-wa901nd-v4"
+               ;;
        *"TL-WDR3500")
                name="tl-wdr3500"
                ;;
index 2fc1d1040a66168d05d128752c4743a346c2c933..beb29b9d053c5172813799e515bb6d732691bc2b 100755 (executable)
@@ -338,6 +338,7 @@ platform_check_image() {
        tl-wa901nd | \
        tl-wa901nd-v2 | \
        tl-wa901nd-v3 | \
+       tl-wa901nd-v4 | \
        tl-wdr3500 | \
        tl-wdr4300 | \
        tl-wdr4900-v2 | \
index 96a5ae232cfd0a0b9a0e9b0befb5ad2ed50705ee..e2ff8267bf5208775d46adde333b2bd2483f58a2 100644 (file)
@@ -118,6 +118,7 @@ CONFIG_ATH79_MACH_TL_WA7210N_V2=y
 CONFIG_ATH79_MACH_TL_WA830RE_V2=y
 CONFIG_ATH79_MACH_TL_WA901ND=y
 CONFIG_ATH79_MACH_TL_WA901ND_V2=y
+CONFIG_ATH79_MACH_TL_WA901ND_V4=y
 CONFIG_ATH79_MACH_TL_WAX50RE=y
 CONFIG_ATH79_MACH_TL_WDR3500=y
 CONFIG_ATH79_MACH_TL_WDR4300=y
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/mach-tl-wa901nd-v4.c b/target/linux/ar71xx/files/arch/mips/ath79/mach-tl-wa901nd-v4.c
new file mode 100644 (file)
index 0000000..9c651bb
--- /dev/null
@@ -0,0 +1,112 @@
+/*
+ *  TP-LINK TL-WA901ND v4 board
+ *
+ *  Copyright (C) 2015 Matthias Schiffer <mschiffer@universe-factory.net>
+ *  Copyright (C) 2016 Tiziano Bacocco <tizbac2@gmail.com>
+ *
+ *  This program is free software; you can redistribute it and/or modify it
+ *  under the terms of the GNU General Public License version 2 as published
+ *  by the Free Software Foundation.
+ */
+
+#include <linux/gpio.h>
+#include <linux/platform_device.h>
+
+#include <asm/mach-ath79/ath79.h>
+#include <asm/mach-ath79/ar71xx_regs.h>
+
+#include "common.h"
+#include "dev-eth.h"
+#include "dev-gpio-buttons.h"
+#include "dev-leds-gpio.h"
+#include "dev-m25p80.h"
+#include "dev-wmac.h"
+#include "machtypes.h"
+
+
+#define TL_WA901ND_V4_GPIO_LED_QSS             3
+#define TL_WA901ND_V4_GPIO_LED_LAN             7
+#define TL_WA901ND_V4_GPIO_LED_WLAN            8
+#define TL_WA901ND_V4_GPIO_LED_SYSTEM          18
+
+#define TL_WA901ND_V4_GPIO_BTN_RESET           1
+
+#define TL_WA901ND_V4_KEYS_POLL_INTERVAL       20
+#define TL_WA901ND_V4_KEYS_DEBOUNCE_INTERVAL   (3 * TL_WA901ND_V4_KEYS_POLL_INTERVAL)
+
+
+static struct gpio_led TL_WA901ND_V4_leds_gpio[] __initdata = {
+       {
+               .name           = "tp-link:green:qss",
+               .gpio           = TL_WA901ND_V4_GPIO_LED_QSS,
+               .active_low     = 1,
+       },
+       {
+               .name           = "tp-link:green:lan",
+               .gpio           = TL_WA901ND_V4_GPIO_LED_LAN,
+               .active_low     = 1,
+       },
+       {
+               .name           = "tp-link:green:wlan",
+               .gpio           = TL_WA901ND_V4_GPIO_LED_WLAN,
+               .active_low     = 1,
+       },
+       {
+               .name           = "tp-link:green:system",
+               .gpio           = TL_WA901ND_V4_GPIO_LED_SYSTEM,
+               .active_low     = 1,
+       },
+};
+
+static struct gpio_keys_button TL_WA901ND_V4_gpio_keys[] __initdata = {
+       {
+               .desc           = "Reset button",
+               .type           = EV_KEY,
+               .code           = KEY_RESTART,
+               .debounce_interval = TL_WA901ND_V4_KEYS_DEBOUNCE_INTERVAL,
+               .gpio           = TL_WA901ND_V4_GPIO_BTN_RESET,
+               .active_low     = 1,
+       }
+};
+
+
+static const char *tl_wa901nd_v4_part_probes[] = {
+       "tp-link",
+       NULL,
+};
+
+static struct flash_platform_data tl_wa901nd_v4_flash_data = {
+       .part_probes    = tl_wa901nd_v4_part_probes,
+};
+
+
+static void __init TL_WA901ND_V4_setup(void)
+{
+       u8 *mac = (u8 *) KSEG1ADDR(0x1f01fc00);
+       u8 *ee = (u8 *) KSEG1ADDR(0x1fff1000);
+
+       ath79_register_m25p80(&tl_wa901nd_v4_flash_data);
+
+       ath79_register_leds_gpio(-1, ARRAY_SIZE(TL_WA901ND_V4_leds_gpio),
+                                TL_WA901ND_V4_leds_gpio);
+
+       ath79_register_gpio_keys_polled(-1, TL_WA901ND_V4_KEYS_POLL_INTERVAL,
+                                       ARRAY_SIZE(TL_WA901ND_V4_gpio_keys),
+                                       TL_WA901ND_V4_gpio_keys);
+
+       ath79_register_mdio(0, 0x0);
+
+       ath79_init_mac(ath79_eth0_data.mac_addr, mac, 1);
+       ath79_init_mac(ath79_eth1_data.mac_addr, mac, -1);
+
+       ath79_switch_data.phy4_mii_en = 1;
+
+       ath79_register_eth(0);
+       ath79_register_eth(1);
+
+       ath79_register_wmac(ee, mac);
+
+}
+
+MIPS_MACHINE(ATH79_MACH_TL_WA901ND_V4, "TL-WA901ND-v4", "TP-LINK TL-WA901ND v4",
+            TL_WA901ND_V4_setup);
index cd77373ab3955c33893552f8a23a0fd2760e24d1..6fb375fa21ffbe676d0b64fe3ed35d4fac36099c 100644 (file)
@@ -688,7 +688,15 @@ define Device/tl-wa901nd-v3
     DEVICE_PROFILE := TLWA901
     TPLINK_HWID := 0x09010003
 endef
-TARGET_DEVICES += tl-wa901nd-v3
+
+define Device/tl-wa901nd-v4
+    $(Device/tplink-4mlzma)
+    BOARDNAME := TL-WA901ND-v4
+    DEVICE_PROFILE := TLWA901
+    TPLINK_HWID := 0x09010004
+endef
+
+TARGET_DEVICES += tl-wa901nd-v3 tl-wa901nd-v4
 
 define Device/tl-wa7210n-v2
     $(Device/tplink-4mlzma)
diff --git a/target/linux/ar71xx/patches-3.18/907-MIPS-ath79-add-tl-wa901nd-v4-support.patch b/target/linux/ar71xx/patches-3.18/907-MIPS-ath79-add-tl-wa901nd-v4-support.patch
new file mode 100644 (file)
index 0000000..ebd9e52
--- /dev/null
@@ -0,0 +1,38 @@
+--- a/arch/mips/ath79/machtypes.h      2016-04-12 21:08:09.309541276 +0200
++++ b/arch/mips/ath79/machtypes.h      2016-04-12 21:08:43.200013377 +0200
+@@ -152,6 +152,7 @@
+       ATH79_MACH_TL_WA901ND,          /* TP-LINK TL-WA901ND */
+       ATH79_MACH_TL_WA901ND_V2,       /* TP-LINK TL-WA901ND v2 */
+       ATH79_MACH_TL_WA901ND_V3,       /* TP-LINK TL-WA901ND v3 */
++      ATH79_MACH_TL_WA901ND_V4,       /* TP-LINK TL-WA901ND v4 */
+       ATH79_MACH_TL_WDR3500,          /* TP-LINK TL-WDR3500 */
+       ATH79_MACH_TL_WDR4300,          /* TP-LINK TL-WDR4300 */
+       ATH79_MACH_TL_WDR4900_V2,       /* TP-LINK TL-WDR4900 v2 */
+--- a/arch/mips/ath79/Kconfig  2016-04-12 21:00:07.267269819 +0200
++++ b/arch/mips/ath79/Kconfig  2016-04-12 21:00:08.803199911 +0200
+@@ -1023,6 +1023,15 @@
+       select ATH79_DEV_M25P80
+       select ATH79_DEV_WMAC
+
++config ATH79_MACH_TL_WA901ND_V4
++      bool "TP-LINK TL-WA901ND v4 support"
++      select SOC_QCA956X
++      select ATH79_DEV_ETH
++      select ATH79_DEV_GPIO_BUTTONS
++      select ATH79_DEV_LEDS_GPIO
++      select ATH79_DEV_M25P80
++      select ATH79_DEV_WMAC
++
+ config ATH79_MACH_TL_WDR3500
+       bool "TP-LINK TL-WDR3500 board support"
+       select SOC_AR934X
+--- a/arch/mips/ath79/Makefile 2016-04-12 21:03:21.974455904 +0200
++++ b/arch/mips/ath79/Makefile 2016-04-12 21:02:56.115621524 +0200
+@@ -128,6 +128,7 @@
+ obj-$(CONFIG_ATH79_MACH_TL_WA830RE_V2)        += mach-tl-wa830re-v2.o
+ obj-$(CONFIG_ATH79_MACH_TL_WA901ND)   += mach-tl-wa901nd.o
+ obj-$(CONFIG_ATH79_MACH_TL_WA901ND_V2)        += mach-tl-wa901nd-v2.o
++obj-$(CONFIG_ATH79_MACH_TL_WA901ND_V4)        += mach-tl-wa901nd-v4.o
+ obj-$(CONFIG_ATH79_MACH_TL_WDR3500)     += mach-tl-wdr3500.o
+ obj-$(CONFIG_ATH79_MACH_TL_WDR4300)     += mach-tl-wdr4300.o
+ obj-$(CONFIG_ATH79_MACH_TL_WR741ND)   += mach-tl-wr741nd.o
index 43840a953ce7998fb215226893b9b553a89bd985..6df869d59a6138d4c0dd1fbec5337a71c31eccd3 100644 (file)
@@ -52,6 +52,7 @@
 #define HWID_TL_WA801ND_V2     0x08010002
 #define HWID_TL_WA901ND_V1     0x09010001
 #define HWID_TL_WA901ND_V2     0x09010002
+#define HWID_TL_WA901ND_V4     0x09010004
 #define HWID_TL_WDR4300_V1_IL  0x43008001
 #define HWID_TL_WDR4900_V1     0x49000001
 #define HWID_TL_WR703N_V1      0x07030101
@@ -305,6 +306,11 @@ static struct board_info boards[] = {
                .hw_id          = HWID_TL_WA901ND_V2,
                .hw_rev         = 1,
                .layout_id      = "4M",
+       }, {
+               .id             = "TL-WA901NDv4",
+               .hw_id          = HWID_TL_WA901ND_V4,
+               .hw_rev         = 1,
+               .layout_id      = "4Mlzma",
        }, {
                .id             = "TL-WDR4300v1",
                .hw_id          = HWID_TL_WDR4300_V1_IL,