Makefile cleanup and explicitely disable pam headers checking which will cause compil...
authorFlorian Fainelli <florian@openwrt.org>
Mon, 20 Oct 2008 15:19:50 +0000 (15:19 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Mon, 20 Oct 2008 15:19:50 +0000 (15:19 +0000)
SVN-Revision: 13016

utils/at/Makefile
utils/at/patches/120-no_pam.patch [new file with mode: 0644]

index 3f438b23c831692b251ddc93057c64e8e293c185..91875adee3d5882429e03dd32e117c556e41d32a 100644 (file)
@@ -34,8 +34,11 @@ endef
 export SENDMAIL=/bin/true
 EXTRA_CFLAGS:=-DNEED_YYWRAP -I$(PKG_BUILD_DIR) -I$(STAGING_DIR)/usr/include/libelf \
                -L$(STAGING_DIR)/usr/lib
-CONFIGURE_ARGS+=--with-daemon_username=nobody --with-daemon_groupname=nogroup \
-               --with-jobdir=/var/spool/cron/atjobs --with-atspool=/var/spool/cron/atspool
+CONFIGURE_ARGS+=--with-daemon_username=nobody \
+               --with-daemon_groupname=nogroup \
+               --with-jobdir=/var/spool/cron/atjobs \
+               --with-atspool=/var/spool/cron/atspool \
+               --without-pam \
 
 define Package/at/install
        $(INSTALL_DIR) $(1)/usr/bin $(1)/usr/sbin $(1)/etc/init.d/
diff --git a/utils/at/patches/120-no_pam.patch b/utils/at/patches/120-no_pam.patch
new file mode 100644 (file)
index 0000000..905dbf9
--- /dev/null
@@ -0,0 +1,56 @@
+diff -urN at-3.1.10ubuntu4/configure at-3.1.10ubuntu4.new/configure
+--- at-3.1.10ubuntu4/configure 2006-06-28 04:21:49.000000000 +0200
++++ at-3.1.10ubuntu4.new/configure     2008-10-20 17:20:27.000000000 +0200
+@@ -2687,50 +2687,8 @@
+ fi
+ done
+-for ac_hdr in security/pam_appl.h
+-do
+-ac_safe=`echo "$ac_hdr" | sed 'y%./+-%__p_%'`
+-echo $ac_n "checking for $ac_hdr""... $ac_c" 1>&6
+-echo "configure:2695: checking for $ac_hdr" >&5
+-if eval "test \"`echo '$''{'ac_cv_header_$ac_safe'+set}'`\" = set"; then
+-  echo $ac_n "(cached) $ac_c" 1>&6
+-else
+-  cat > conftest.$ac_ext <<EOF
+-#line 2700 "configure"
+-#include "confdefs.h"
+-#include <$ac_hdr>
+-EOF
+-ac_try="$ac_cpp conftest.$ac_ext >/dev/null 2>conftest.out"
+-{ (eval echo configure:2705: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }
+-ac_err=`grep -v '^ *+' conftest.out | grep -v "^conftest.${ac_ext}\$"`
+-if test -z "$ac_err"; then
+-  rm -rf conftest*
+-  eval "ac_cv_header_$ac_safe=yes"
+-else
+-  echo "$ac_err" >&5
+-  echo "configure: failed program was:" >&5
+-  cat conftest.$ac_ext >&5
+-  rm -rf conftest*
+-  eval "ac_cv_header_$ac_safe=no"
+-fi
+-rm -f conftest*
+-fi
+-if eval "test \"`echo '$ac_cv_header_'$ac_safe`\" = yes"; then
+-  echo "$ac_t""yes" 1>&6
+-    ac_tr_hdr=HAVE_`echo $ac_hdr | sed 'y%abcdefghijklmnopqrstuvwxyz./-%ABCDEFGHIJKLMNOPQRSTUVWXYZ___%'`
+-  cat >> confdefs.h <<EOF
+-#define $ac_tr_hdr 1
+-EOF
+- PAMLIB="-lpam"
+-                                    cat >> confdefs.h <<\EOF
+-#define HAVE_PAM 1
+-EOF
+-
+-else
+-  echo "$ac_t""no" 1>&6
+-fi
+-done
+-
++# Disable PAM
++echo "$ac_t""no" 1>&6
+ # Extract the first word of "sendmail", so it can be a program name with args.