net/quagga: honor configure.ac patch changes
authorAlexandros C. Couloumbis <alex@ozo.com>
Wed, 27 Oct 2010 13:20:36 +0000 (13:20 +0000)
committerAlexandros C. Couloumbis <alex@ozo.com>
Wed, 27 Oct 2010 13:20:36 +0000 (13:20 +0000)
SVN-Revision: 23665

net/quagga/Makefile

index 19f6f4c1659f6ddde65e0d0beb595d7eb53bc124..4fe10f4ddadf93f918f6b301934c11c89faac86f 100644 (file)
@@ -157,6 +157,13 @@ ifneq ($(CONFIG_PACKAGE_quagga-ripngd),)
   CONFIGURE_ARGS+= --enable-ripngd
 endif
 
   CONFIGURE_ARGS+= --enable-ripngd
 endif
 
+define Build/Configure
+       (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status}; \
+               autoconf \
+       );
+       $(call Build/Configure/Default)
+endef
+
 define Package/quagga/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/zebra $(1)/usr/sbin/
 define Package/quagga/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/zebra $(1)/usr/sbin/