[packages] collectd: set postgresql lib location explicitly (closes: #7247)
authorNicolas Thill <nico@openwrt.org>
Sat, 14 Aug 2010 14:25:30 +0000 (14:25 +0000)
committerNicolas Thill <nico@openwrt.org>
Sat, 14 Aug 2010 14:25:30 +0000 (14:25 +0000)
SVN-Revision: 22640

utils/collectd/Makefile

index 6119572b7776f64380f6685b75f006b9139381f3..69007d80d6e526eacde844e560e774e3975cf7ca 100644 (file)
@@ -167,6 +167,10 @@ ifneq ($(CONFIG_PACKAGE_collectd-mod-ascent),)
        CPPFLAGS="$$$$CPPFLAGS -I$(STAGING_DIR)/usr/include/libxml2"
 endif
 
        CPPFLAGS="$$$$CPPFLAGS -I$(STAGING_DIR)/usr/include/libxml2"
 endif
 
+ifneq ($(CONFIG_PACKAGE_collectd-mod-postgresql),)
+  CONFIGURE_ARGS+= --with-libpq="$(STAGING_DIR)/usr/"
+endif
+
 ifneq ($(CONFIG_PACKAGE_collectd-mod-mysql),)
   CONFIGURE_ARGS+= --with-libmysql="$(STAGING_DIR)/usr/"
 endif
 ifneq ($(CONFIG_PACKAGE_collectd-mod-mysql),)
   CONFIGURE_ARGS+= --with-libmysql="$(STAGING_DIR)/usr/"
 endif