ar71xx: add kernel support for the OpenMesh MR1750 board
authorJohn Crispin <john@openwrt.org>
Mon, 14 Sep 2015 20:10:43 +0000 (20:10 +0000)
committerJohn Crispin <john@openwrt.org>
Mon, 14 Sep 2015 20:10:43 +0000 (20:10 +0000)
Signed-off-by: Sven Eckelmann <sven@open-mesh.com>
SVN-Revision: 46926

target/linux/ar71xx/config-4.1
target/linux/ar71xx/files/arch/mips/ath79/mach-mr1750.c [new file with mode: 0644]
target/linux/ar71xx/patches-4.1/815-MIPS-ath79-add-mr1750-support.patch [new file with mode: 0644]

index df82aa4f97773ed08d6904bb9af5b237fe3f8a89..18df7862deaf79a6694108e96b529a16fcd83cf6 100644 (file)
@@ -82,6 +82,7 @@ CONFIG_ATH79_MACH_JWAP003=y
 CONFIG_ATH79_MACH_MC_MAC1200R=y
 CONFIG_ATH79_MACH_MR12=y
 CONFIG_ATH79_MACH_MR16=y
 CONFIG_ATH79_MACH_MC_MAC1200R=y
 CONFIG_ATH79_MACH_MR12=y
 CONFIG_ATH79_MACH_MR16=y
+CONFIG_ATH79_MACH_MR1750=y
 CONFIG_ATH79_MACH_MR600=y
 CONFIG_ATH79_MACH_MR900=y
 CONFIG_ATH79_MACH_MYNET_N600=y
 CONFIG_ATH79_MACH_MR600=y
 CONFIG_ATH79_MACH_MR900=y
 CONFIG_ATH79_MACH_MYNET_N600=y
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/mach-mr1750.c b/target/linux/ar71xx/files/arch/mips/ath79/mach-mr1750.c
new file mode 100644 (file)
index 0000000..8ace02f
--- /dev/null
@@ -0,0 +1,129 @@
+/*
+ * MR1750 board support
+ *
+ * Copyright (c) 2012 Qualcomm Atheros
+ * Copyright (c) 2012-2013 Marek Lindner <marek@open-mesh.com>
+ *
+ * Permission to use, copy, modify, and/or distribute this software for any
+ * purpose with or without fee is hereby granted, provided that the above
+ * copyright notice and this permission notice appear in all copies.
+ *
+ * THE SOFTWARE IS PROVIDED "AS IS" AND THE AUTHOR DISCLAIMS ALL WARRANTIES
+ * WITH REGARD TO THIS SOFTWARE INCLUDING ALL IMPLIED WARRANTIES OF
+ * MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR
+ * ANY SPECIAL, DIRECT, INDIRECT, OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES
+ * WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN
+ * ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF
+ * OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
+ *
+ */
+
+#include <linux/platform_device.h>
+#include <linux/ar8216_platform.h>
+
+#include <asm/mach-ath79/ar71xx_regs.h>
+
+#include "common.h"
+#include "dev-ap9x-pci.h"
+#include "dev-gpio-buttons.h"
+#include "dev-eth.h"
+#include "dev-leds-gpio.h"
+#include "dev-m25p80.h"
+#include "dev-wmac.h"
+#include "machtypes.h"
+#include "pci.h"
+
+#define MR1750_GPIO_LED_LAN            12
+#define MR1750_GPIO_LED_WLAN_2G                13
+#define MR1750_GPIO_LED_STATUS_GREEN   19
+#define MR1750_GPIO_LED_STATUS_RED     21
+#define MR1750_GPIO_LED_POWER          22
+#define MR1750_GPIO_LED_WLAN_5G                23
+
+#define MR1750_GPIO_BTN_RESET          17
+
+#define MR1750_KEYS_POLL_INTERVAL      20      /* msecs */
+#define MR1750_KEYS_DEBOUNCE_INTERVAL  (3 * MR1750_KEYS_POLL_INTERVAL)
+
+#define MR1750_MAC0_OFFSET             0
+#define MR1750_WMAC_CALDATA_OFFSET     0x1000
+
+static struct gpio_led mr1750_leds_gpio[] __initdata = {
+       {
+               .name           = "mr1750:blue:power",
+               .gpio           = MR1750_GPIO_LED_POWER,
+               .active_low     = 1,
+       },
+       {
+               .name           = "mr1750:blue:wan",
+               .gpio           = MR1750_GPIO_LED_LAN,
+               .active_low     = 1,
+       },
+       {
+               .name           = "mr1750:blue:wlan24",
+               .gpio           = MR1750_GPIO_LED_WLAN_2G,
+               .active_low     = 1,
+       },
+       {
+               .name           = "mr1750:blue:wlan58",
+               .gpio           = MR1750_GPIO_LED_WLAN_5G,
+               .active_low     = 1,
+       },
+       {
+               .name           = "mr1750:green:status",
+               .gpio           = MR1750_GPIO_LED_STATUS_GREEN,
+               .active_low     = 1,
+       },
+       {
+               .name           = "mr1750:red:status",
+               .gpio           = MR1750_GPIO_LED_STATUS_RED,
+               .active_low     = 1,
+       },
+};
+
+static struct gpio_keys_button mr1750_gpio_keys[] __initdata = {
+       {
+               .desc           = "Reset button",
+               .type           = EV_KEY,
+               .code           = KEY_RESTART,
+               .debounce_interval = MR1750_KEYS_DEBOUNCE_INTERVAL,
+               .gpio           = MR1750_GPIO_BTN_RESET,
+               .active_low     = 1,
+       },
+};
+
+static void __init mr1750_setup(void)
+{
+       u8 *art = (u8 *)KSEG1ADDR(0x1fff0000);
+       u8 mac[6];
+
+       ath79_eth0_pll_data.pll_1000 = 0xbe000101;
+       ath79_eth0_pll_data.pll_100 = 0x80000101;
+       ath79_eth0_pll_data.pll_10 = 0x80001313;
+
+       ath79_register_m25p80(NULL);
+
+       ath79_register_leds_gpio(-1, ARRAY_SIZE(mr1750_leds_gpio),
+                                mr1750_leds_gpio);
+       ath79_register_gpio_keys_polled(-1, MR1750_KEYS_POLL_INTERVAL,
+                                       ARRAY_SIZE(mr1750_gpio_keys),
+                                       mr1750_gpio_keys);
+
+       ath79_init_mac(mac, art + MR1750_MAC0_OFFSET, 1);
+       ath79_register_wmac(art + MR1750_WMAC_CALDATA_OFFSET, mac);
+       ath79_register_pci();
+
+       ath79_setup_qca955x_eth_cfg(QCA955X_ETH_CFG_RGMII_EN);
+       ath79_register_mdio(0, 0x0);
+
+       ath79_init_mac(ath79_eth0_data.mac_addr, art + MR1750_MAC0_OFFSET, 0);
+
+       /* GMAC0 is connected to the RMGII interface */
+       ath79_eth0_data.phy_if_mode = PHY_INTERFACE_MODE_RGMII;
+       ath79_eth0_data.phy_mask = BIT(5);
+       ath79_eth0_data.mii_bus_dev = &ath79_mdio0_device.dev;
+
+       ath79_register_eth(0);
+}
+
+MIPS_MACHINE(ATH79_MACH_MR1750, "MR1750", "OpenMesh MR1750", mr1750_setup);
diff --git a/target/linux/ar71xx/patches-4.1/815-MIPS-ath79-add-mr1750-support.patch b/target/linux/ar71xx/patches-4.1/815-MIPS-ath79-add-mr1750-support.patch
new file mode 100644 (file)
index 0000000..d802a12
--- /dev/null
@@ -0,0 +1,39 @@
+--- a/arch/mips/ath79/Kconfig
++++ b/arch/mips/ath79/Kconfig
+@@ -763,6 +763,16 @@ config ATH79_MACH_CAP4200AG
+       select ATH79_DEV_M25P80
+       select ATH79_DEV_WMAC
++config ATH79_MACH_MR1750
++      bool "OpenMesh MR1750 board support"
++      select SOC_QCA955X
++      select ATH79_DEV_AP9X_PCI if PCI
++      select ATH79_DEV_ETH
++      select ATH79_DEV_GPIO_BUTTONS
++      select ATH79_DEV_LEDS_GPIO
++      select ATH79_DEV_M25P80
++      select ATH79_DEV_WMAC
++
+ config ATH79_MACH_MR900
+       bool "OpenMesh MR900 board support"
+       select SOC_QCA955X
+--- a/arch/mips/ath79/Makefile
++++ b/arch/mips/ath79/Makefile
+@@ -80,6 +80,7 @@ obj-$(CONFIG_ATH79_MACH_HORNET_UB)   += ma
+ obj-$(CONFIG_ATH79_MACH_MC_MAC1200R)     += mach-mc-mac1200r.o
+ obj-$(CONFIG_ATH79_MACH_MR12)         += mach-mr12.o
+ obj-$(CONFIG_ATH79_MACH_MR16)         += mach-mr16.o
++obj-$(CONFIG_ATH79_MACH_MR1750)               += mach-mr1750.o
+ obj-$(CONFIG_ATH79_MACH_MR600)                += mach-mr600.o
+ obj-$(CONFIG_ATH79_MACH_MR900)                += mach-mr900.o
+ obj-$(CONFIG_ATH79_MACH_MYNET_N600)   += mach-mynet-n600.o
+--- a/arch/mips/ath79/machtypes.h
++++ b/arch/mips/ath79/machtypes.h
+@@ -69,6 +69,7 @@ enum ath79_mach_type {
+       ATH79_MACH_HORNET_UB,           /* ALFA Networks Hornet-UB */
+       ATH79_MACH_MR12,                /* Cisco Meraki MR12 */
+       ATH79_MACH_MR16,                /* Cisco Meraki MR16 */
++      ATH79_MACH_MR1750,              /* OpenMesh MR1750 */
+       ATH79_MACH_MR600V2,             /* OpenMesh MR600v2 */
+       ATH79_MACH_MR600,               /* OpenMesh MR600 */
+       ATH79_MACH_MR900,               /* OpenMesh MR900 */