include: make dtb argument optional in MkFIT
authorFelix Fietkau <nbd@openwrt.org>
Sun, 10 May 2015 11:46:50 +0000 (11:46 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sun, 10 May 2015 11:46:50 +0000 (11:46 +0000)
As mkits.sh makes the -d argument optional, we'll make this same
argument optional in the MkFIT function as well.

With this change, MkFIT can be used both to generate FIT images with DT,
and without DT.

Signed-off-by: Mathieu Olivari <mathieu@qca.qualcomm.com>
SVN-Revision: 45660

include/image.mk

index 788d593f949d94367cf672123cb82a6456a92495..a6237ff2e251ea66bd8ee4d7565df661449a4c6d 100644 (file)
@@ -121,7 +121,7 @@ endef
 
 define Image/BuildKernel/MkFIT
        $(TOPDIR)/scripts/mkits.sh \
-               -D $(1) -o $(KDIR)/fit-$(1).its -k $(2) -d $(3) -C $(4) -a $(5) -e $(6) \
+               -D $(1) -o $(KDIR)/fit-$(1).its -k $(2) $(if $(3),-d $(3)) -C $(4) -a $(5) -e $(6) \
                -A $(ARCH) -v $(LINUX_VERSION)
        PATH=$(LINUX_DIR)/scripts/dtc:$(PATH) mkimage -f $(KDIR)/fit-$(1).its $(KDIR)/fit-$(1)$(7).itb
 endef