spi-gpio-old: 2.6.36 compile fix
authorMichael Büsch <mb@bu3sch.de>
Thu, 7 Oct 2010 13:26:39 +0000 (13:26 +0000)
committerMichael Büsch <mb@bu3sch.de>
Thu, 7 Oct 2010 13:26:39 +0000 (13:26 +0000)
SVN-Revision: 23292

target/linux/generic/patches-2.6.36/921-gpio_spi_driver.patch

index 3ff575e696dfa27ac9a07aaea1533deb65068f19..9c80f9025b98d27c26a77ec46edae8adf452879b 100644 (file)
@@ -6,8 +6,15 @@ Please use the new mainline SPI-GPIO driver, as of 2.6.29.
 
 
 
 
 
 
+---
+ drivers/spi/Kconfig              |    9 +
+ drivers/spi/Makefile             |    1 
+ drivers/spi/spi_gpio_old.c       |  251 +++++++++++++++++++++++++++++++++++++++
+ include/linux/spi/spi_gpio_old.h |   73 +++++++++++
+ 4 files changed, 334 insertions(+)
+
 --- /dev/null
 --- /dev/null
-+++ b/include/linux/spi/spi_gpio_old.h
++++ linux-2.6.36-rc7/include/linux/spi/spi_gpio_old.h
 @@ -0,0 +1,73 @@
 +/*
 + * spi_gpio interface to platform code
 @@ -0,0 +1,73 @@
 +/*
 + * spi_gpio interface to platform code
@@ -83,7 +90,7 @@ Please use the new mainline SPI-GPIO driver, as of 2.6.29.
 +
 +#endif /* _LINUX_SPI_SPI_GPIO */
 --- /dev/null
 +
 +#endif /* _LINUX_SPI_SPI_GPIO */
 --- /dev/null
-+++ b/drivers/spi/spi_gpio_old.c
++++ linux-2.6.36-rc7/drivers/spi/spi_gpio_old.c
 @@ -0,0 +1,251 @@
 +/*
 + * Bitbanging SPI bus driver using GPIO API
 @@ -0,0 +1,251 @@
 +/*
 + * Bitbanging SPI bus driver using GPIO API
@@ -167,25 +174,25 @@ Please use the new mainline SPI-GPIO driver, as of 2.6.29.
 +static u32 spi_gpio_txrx_mode0(struct spi_device *spi,
 +                             unsigned nsecs, u32 word, u8 bits)
 +{
 +static u32 spi_gpio_txrx_mode0(struct spi_device *spi,
 +                             unsigned nsecs, u32 word, u8 bits)
 +{
-+      return bitbang_txrx_be_cpha0(spi, nsecs, 0, word, bits);
++      return bitbang_txrx_be_cpha0(spi, nsecs, 0, 0, word, bits);
 +}
 +
 +static u32 spi_gpio_txrx_mode1(struct spi_device *spi,
 +                             unsigned nsecs, u32 word, u8 bits)
 +{
 +}
 +
 +static u32 spi_gpio_txrx_mode1(struct spi_device *spi,
 +                             unsigned nsecs, u32 word, u8 bits)
 +{
-+      return bitbang_txrx_be_cpha1(spi, nsecs, 0, word, bits);
++      return bitbang_txrx_be_cpha1(spi, nsecs, 0, 0, word, bits);
 +}
 +
 +static u32 spi_gpio_txrx_mode2(struct spi_device *spi,
 +                             unsigned nsecs, u32 word, u8 bits)
 +{
 +}
 +
 +static u32 spi_gpio_txrx_mode2(struct spi_device *spi,
 +                             unsigned nsecs, u32 word, u8 bits)
 +{
-+      return bitbang_txrx_be_cpha0(spi, nsecs, 1, word, bits);
++      return bitbang_txrx_be_cpha0(spi, nsecs, 1, 0, word, bits);
 +}
 +
 +static u32 spi_gpio_txrx_mode3(struct spi_device *spi,
 +                             unsigned nsecs, u32 word, u8 bits)
 +{
 +}
 +
 +static u32 spi_gpio_txrx_mode3(struct spi_device *spi,
 +                             unsigned nsecs, u32 word, u8 bits)
 +{
-+      return bitbang_txrx_be_cpha1(spi, nsecs, 1, word, bits);
++      return bitbang_txrx_be_cpha1(spi, nsecs, 1, 0, word, bits);
 +}
 +
 +static void spi_gpio_chipselect(struct spi_device *dev, int on)
 +}
 +
 +static void spi_gpio_chipselect(struct spi_device *dev, int on)
@@ -336,8 +343,8 @@ Please use the new mainline SPI-GPIO driver, as of 2.6.29.
 +MODULE_AUTHOR("Michael Buesch");
 +MODULE_DESCRIPTION("Platform independent GPIO bitbanging SPI driver");
 +MODULE_LICENSE("GPL v2");
 +MODULE_AUTHOR("Michael Buesch");
 +MODULE_DESCRIPTION("Platform independent GPIO bitbanging SPI driver");
 +MODULE_LICENSE("GPL v2");
---- a/drivers/spi/Kconfig
-+++ b/drivers/spi/Kconfig
+--- linux-2.6.36-rc7.orig/drivers/spi/Kconfig
++++ linux-2.6.36-rc7/drivers/spi/Kconfig
 @@ -143,6 +143,15 @@ config SPI_GPIO
          GPIO operations, you should be able to leverage that for better
          speed with a custom version of this driver; see the source code.
 @@ -143,6 +143,15 @@ config SPI_GPIO
          GPIO operations, you should be able to leverage that for better
          speed with a custom version of this driver; see the source code.
@@ -354,8 +361,8 @@ Please use the new mainline SPI-GPIO driver, as of 2.6.29.
  config SPI_IMX
        tristate "Freescale i.MX SPI controllers"
        depends on ARCH_MXC
  config SPI_IMX
        tristate "Freescale i.MX SPI controllers"
        depends on ARCH_MXC
---- a/drivers/spi/Makefile
-+++ b/drivers/spi/Makefile
+--- linux-2.6.36-rc7.orig/drivers/spi/Makefile
++++ linux-2.6.36-rc7/drivers/spi/Makefile
 @@ -23,6 +23,7 @@ obj-$(CONFIG_SPI_DW_PCI)             += dw_spi_pci.
  obj-$(CONFIG_SPI_DW_MMIO)             += dw_spi_mmio.o
  obj-$(CONFIG_SPI_EP93XX)              += ep93xx_spi.o
 @@ -23,6 +23,7 @@ obj-$(CONFIG_SPI_DW_PCI)             += dw_spi_pci.
  obj-$(CONFIG_SPI_DW_MMIO)             += dw_spi_mmio.o
  obj-$(CONFIG_SPI_EP93XX)              += ep93xx_spi.o