fix kmod-hostap build on 2.4, add kmod-hostap-cs (closes: #1957)
authorNicolas Thill <nico@openwrt.org>
Wed, 26 Sep 2007 02:49:50 +0000 (02:49 +0000)
committerNicolas Thill <nico@openwrt.org>
Wed, 26 Sep 2007 02:49:50 +0000 (02:49 +0000)
SVN-Revision: 9030

package/hostap-driver/Makefile
package/kernel/modules/wireless.mk

index 2b903f997888bb9918c5b7983fc1fc5977fc7057..5be9f9eb59dda12cff2ce215472656c03a49a926 100644 (file)
@@ -25,9 +25,11 @@ endif
 define KernelPackage/hostap/Default/2.4
   VERSION:=$(LINUX_VERSION)+$(PKG_VERSION)-$(BOARD)-$(PKG_RELEASE)
 endef
 define KernelPackage/hostap/Default/2.4
   VERSION:=$(LINUX_VERSION)+$(PKG_VERSION)-$(BOARD)-$(PKG_RELEASE)
 endef
+
 define KernelPackage/hostap/Default/2.6
   VERSION:=$(LINUX_VERSION)-$(BOARD)-$(PKG_RELEASE)
 endef
 define KernelPackage/hostap/Default/2.6
   VERSION:=$(LINUX_VERSION)-$(BOARD)-$(PKG_RELEASE)
 endef
+
 define KernelPackage/hostap/Default
 $(call KernelPackage/hostap/Default/$(KERNEL))
   SUBMENU:=Wireless Drivers
 define KernelPackage/hostap/Default
 $(call KernelPackage/hostap/Default/$(KERNEL))
   SUBMENU:=Wireless Drivers
@@ -40,14 +42,19 @@ define KernelPackage/hostap/Default/description
  card to act as an IEEE 802.11 access point.
 endef
 
  card to act as an IEEE 802.11 access point.
 endef
 
+
 define KernelPackage/hostap
 $(call KernelPackage/hostap/Default)
 define KernelPackage/hostap
 $(call KernelPackage/hostap/Default)
-  DEPENDS:=@PCI_SUPPORT||PCMCIA_SUPPORT +kmod-ieee80211
   TITLE:=Host AP support for Prism2/2.5/3
   TITLE:=Host AP support for Prism2/2.5/3
+  DEPENDS:=@PCI_SUPPORT||PCMCIA_SUPPORT +kmod-ieee80211
   KCONFIG:=CONFIG_HOSTAP
 endef
   KCONFIG:=CONFIG_HOSTAP
 endef
+
 define KernelPackage/hostap/2.4
 define KernelPackage/hostap/2.4
-  DEPENDS:=+kmod-crypto
+# NOTE: needed to remove the dependency on kmod-ieee80211 in the final ipkg
+  DEPENDS:=
+# NOTE: needed to build the standalone version on 2.4
+  KCONFIG:=
   FILES:= \
        $(PKG_BUILD_DIR)/driver/modules/hostap.$(LINUX_KMOD_SUFFIX) \
        $(PKG_BUILD_DIR)/driver/modules/hostap_crypt_ccmp.$(LINUX_KMOD_SUFFIX) \
   FILES:= \
        $(PKG_BUILD_DIR)/driver/modules/hostap.$(LINUX_KMOD_SUFFIX) \
        $(PKG_BUILD_DIR)/driver/modules/hostap_crypt_ccmp.$(LINUX_KMOD_SUFFIX) \
@@ -55,6 +62,7 @@ define KernelPackage/hostap/2.4
        $(PKG_BUILD_DIR)/driver/modules/hostap_crypt_wep.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,60,hostap hostap_crypt_wep hostap_crypt_tkip hostap_crypt_ccmp)
 endef
        $(PKG_BUILD_DIR)/driver/modules/hostap_crypt_wep.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,60,hostap hostap_crypt_wep hostap_crypt_tkip hostap_crypt_ccmp)
 endef
+
 define KernelPackage/hostap/2.6
   FILES:= \
        $(LINUX_DIR)/drivers/net/wireless/hostap/hostap.$(LINUX_KMOD_SUFFIX)
 define KernelPackage/hostap/2.6
   FILES:= \
        $(LINUX_DIR)/drivers/net/wireless/hostap/hostap.$(LINUX_KMOD_SUFFIX)
@@ -68,17 +76,46 @@ $(call KernelPackage/hostap/Default/description)
  PLX/PCI/CS version of the driver to actually use the driver.
 endef
 
  PLX/PCI/CS version of the driver to actually use the driver.
 endef
 
+
+define KernelPackage/hostap-cs
+$(call KernelPackage/hostap/Default)
+  TITLE:=Host AP driver for PCMCIA adaptors
+  DEPENDS:=@PCMCIA_SUPPORT kmod-hostap +kmod-pcmcia-core
+  KCONFIG:=CONFIG_HOSTAP_CS
+  AUTOLOAD:=$(call AutoLoad,60,hostap_cs)
+endef
+define KernelPackage/hostap-cs/2.4
+# NOTE: needed to build the standalone version on 2.4
+  KCONFIG:=
+  FILES:= \
+       $(PKG_BUILD_DIR)/driver/modules/hostap_cs.$(LINUX_KMOD_SUFFIX)
+endef
+define KernelPackage/hostap-cs/2.6
+  FILES:= \
+       $(LINUX_DIR)/drivers/net/wireless/hostap/hostap_cs.$(LINUX_KMOD_SUFFIX)
+endef
+
+define KernelPackage/hostap-cs/description
+$(call KernelPackage/hostap/Default/description)
+ This package contains the Host AP driver for Prism2/2.5/3 PC cards.
+endef
+
+
 define KernelPackage/hostap-pci
 $(call KernelPackage/hostap/Default)
 define KernelPackage/hostap-pci
 $(call KernelPackage/hostap/Default)
-  DEPENDS:=@PCI_SUPPORT kmod-hostap
   TITLE:=Host AP driver for PCI adaptors
   TITLE:=Host AP driver for PCI adaptors
+  DEPENDS:=@PCI_SUPPORT kmod-hostap
   KCONFIG:=CONFIG_HOSTAP_PCI
   AUTOLOAD:=$(call AutoLoad,60,hostap_pci)
 endef
   KCONFIG:=CONFIG_HOSTAP_PCI
   AUTOLOAD:=$(call AutoLoad,60,hostap_pci)
 endef
+
 define KernelPackage/hostap-pci/2.4
 define KernelPackage/hostap-pci/2.4
+# NOTE: needed to build the standalone version on 2.4
+  KCONFIG:=
   FILES:= \
        $(PKG_BUILD_DIR)/driver/modules/hostap_pci.$(LINUX_KMOD_SUFFIX)
 endef
   FILES:= \
        $(PKG_BUILD_DIR)/driver/modules/hostap_pci.$(LINUX_KMOD_SUFFIX)
 endef
+
 define KernelPackage/hostap-pci/2.6
   FILES:= \
        $(LINUX_DIR)/drivers/net/wireless/hostap/hostap_pci.$(LINUX_KMOD_SUFFIX)
 define KernelPackage/hostap-pci/2.6
   FILES:= \
        $(LINUX_DIR)/drivers/net/wireless/hostap/hostap_pci.$(LINUX_KMOD_SUFFIX)
@@ -89,17 +126,22 @@ $(call KernelPackage/hostap/Default/description)
  This package contains the Host AP driver for Prism2.5 PCI adaptors.
 endef
 
  This package contains the Host AP driver for Prism2.5 PCI adaptors.
 endef
 
+
 define KernelPackage/hostap-plx
 $(call KernelPackage/hostap/Default)
 define KernelPackage/hostap-plx
 $(call KernelPackage/hostap/Default)
+  TITLE:=Host AP driver for PLX9052 based PCI adaptors
   DEPENDS:=@PCI_SUPPORT kmod-hostap
   KCONFIG:=CONFIG_HOSTAP_PLX
   DEPENDS:=@PCI_SUPPORT kmod-hostap
   KCONFIG:=CONFIG_HOSTAP_PLX
-  TITLE:=Host AP driver for PLX9052 based PCI adaptors
   AUTOLOAD:=$(call AutoLoad,60,hostap_plx)
 endef
   AUTOLOAD:=$(call AutoLoad,60,hostap_plx)
 endef
+
 define KernelPackage/hostap-plx/2.4
 define KernelPackage/hostap-plx/2.4
+# NOTE: needed to build the standalone version on 2.4
+  KCONFIG:=
   FILES:= \
        $(PKG_BUILD_DIR)/driver/modules/hostap_plx.$(LINUX_KMOD_SUFFIX)
 endef
   FILES:= \
        $(PKG_BUILD_DIR)/driver/modules/hostap_plx.$(LINUX_KMOD_SUFFIX)
 endef
+
 define KernelPackage/hostap-plx/2.6
   FILES:= \
        $(LINUX_DIR)/drivers/net/wireless/hostap/hostap_plx.$(LINUX_KMOD_SUFFIX)
 define KernelPackage/hostap-plx/2.6
   FILES:= \
        $(LINUX_DIR)/drivers/net/wireless/hostap/hostap_plx.$(LINUX_KMOD_SUFFIX)
@@ -134,5 +176,6 @@ endif
 
 
 $(eval $(call KernelPackage,hostap))
 
 
 $(eval $(call KernelPackage,hostap))
+$(eval $(call KernelPackage,hostap-cs))
 $(eval $(call KernelPackage,hostap-pci))
 $(eval $(call KernelPackage,hostap-plx))
 $(eval $(call KernelPackage,hostap-pci))
 $(eval $(call KernelPackage,hostap-plx))
index a9ec1f5de8e49e81445085578798d1fb313e796e..6887a491a37a3f4945b3c1b6728a37992a39c193 100644 (file)
@@ -8,10 +8,12 @@
 
 WIRELESS_MENU:=Wireless Drivers
 
 
 WIRELESS_MENU:=Wireless Drivers
 
+# NOTE: dependency on 2.6 was removed since it was inherited by kmod-hostap 
+#       and prevented it from even showing up in menuconfig on 2.4
 define KernelPackage/ieee80211
   SUBMENU:=$(WIRELESS_MENU)
   TITLE:=802.11 Networking stack
 define KernelPackage/ieee80211
   SUBMENU:=$(WIRELESS_MENU)
   TITLE:=802.11 Networking stack
-  DEPENDS:=@LINUX_2_6 +kmod-crypto-arc4 +kmod-crypto-aes +kmod-crypto-michael-mic
+  DEPENDS:=+kmod-crypto-arc4 +kmod-crypto-aes +kmod-crypto-michael-mic
   KCONFIG:= \
        CONFIG_IEEE80211 \
        CONFIG_IEEE80211_CRYPT_WEP \
   KCONFIG:= \
        CONFIG_IEEE80211 \
        CONFIG_IEEE80211_CRYPT_WEP \