[package] update mjpg-streamer to revision 74 (#4347)
authorFlorian Fainelli <florian@openwrt.org>
Sun, 8 Feb 2009 13:48:04 +0000 (13:48 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sun, 8 Feb 2009 13:48:04 +0000 (13:48 +0000)
SVN-Revision: 14443

multimedia/mjpg-streamer/Makefile
multimedia/mjpg-streamer/patches/001-no_input_testpictures.patch

index 53b97026695479c3a13d2b772b0d33661f2b533d..f43b1b5a31e82d902303496f3c01a846089fb0fc 100644 (file)
@@ -9,9 +9,9 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mjpg-streamer
-PKG_REV:=68
+PKG_REV:=74
 PKG_VERSION:=r$(PKG_REV)
-PKG_RELEASE:=2
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=https://mjpg-streamer.svn.sourceforge.net/svnroot/mjpg-streamer/mjpg-streamer/
@@ -39,7 +39,7 @@ define Package/mjpg-streamer/install
        $(INSTALL_DIR) $(1)/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/mjpg_streamer $(1)/sbin
        $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(foreach input_plugin,uvc gspcav1,$(PKG_BUILD_DIR)/input_$(input_plugin).so) $(1)/usr/lib
+       $(CP) $(foreach input_plugin,file uvc gspcav1,$(PKG_BUILD_DIR)/input_$(input_plugin).so) $(1)/usr/lib
        $(CP) $(foreach output_plugin,http file autofocus,$(PKG_BUILD_DIR)/output_$(output_plugin).so) $(1)/usr/lib
        $(INSTALL_DIR) $(1)/webcam_www
        $(CP) $(PKG_BUILD_DIR)/www/* $(1)/webcam_www
index 9390cf4c87ddcc7624717f3278e5f26f55c01e44..8ae90be3d8b016483412dcda147cd7746530d671 100644 (file)
@@ -1,12 +1,11 @@
-diff -urN mjpg-streamer-r68/Makefile mjpg-streamer-r68.new/Makefile
---- mjpg-streamer-r68/Makefile 2008-09-27 16:26:56.000000000 +0200
-+++ mjpg-streamer-r68.new/Makefile     2009-01-18 16:11:32.000000000 +0100
-@@ -28,7 +28,7 @@
- APP_BINARY = mjpg_streamer
- # define the names and targets of the plugins
--PLUGINS = input_uvc.so output_file.so output_http.so input_testpicture.so output_autofocus.so input_gspcav1.so
-+PLUGINS = input_uvc.so output_file.so output_http.so output_autofocus.so input_gspcav1.so
- # define the names of object files
- OBJECTS=mjpg_streamer.o utils.o
+diff -urN mjpg-streamer-r74/Makefile mjpg-streamer-r74.new/Makefile
+--- mjpg-streamer-r74/Makefile 2009-02-08 14:51:37.000000000 +0100
++++ mjpg-streamer-r74.new/Makefile     2009-02-08 14:52:48.000000000 +0100
+@@ -31,7 +31,6 @@
+ PLUGINS = input_uvc.so
+ PLUGINS += output_file.so
+ PLUGINS += output_http.so
+-PLUGINS += input_testpicture.so
+ PLUGINS += output_autofocus.so
+ PLUGINS += input_gspcav1.so
+ PLUGINS += input_file.so