ath10k-firmware: add qca6174 firmware (mostly untested)
authorFelix Fietkau <nbd@openwrt.org>
Tue, 10 Nov 2015 12:03:39 +0000 (12:03 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Tue, 10 Nov 2015 12:03:39 +0000 (12:03 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 47437

package/firmware/ath10k-firmware/Makefile

index ac955438672f22ab382fd3967b4d01580afa974e..6b694a6c36816f4b80e07f2ac44dbf4ea6410326 100644 (file)
@@ -23,25 +23,30 @@ include $(INCLUDE_DIR)/package.mk
 
 WMENU:=Wireless Drivers
 
-define Package/ath10k-firmware-qca988x
+define Package/ath10k-firmware-default
   SECTION:=kernel
   CATEGORY:=Kernel modules
   SUBMENU:=$(WMENU)
   URL:=$(PKG_SOURCE_URL)
-  DEFAULT:=PACKAGE_kmod-ath10k
   DEPENDS:=kmod-ath10k
+endef
+
+define Package/ath10k-firmware-qca988x
+$(Package/ath10k-firmware-default)
+  DEFAULT:=PACKAGE_kmod-ath10k
   TITLE:=ath10k firmware for QCA988x devices
 endef
 
 define Package/ath10k-firmware-qca99x0
-  SECTION:=kernel
-  CATEGORY:=Kernel modules
-  SUBMENU:=$(WMENU)
-  URL:=$(PKG_SOURCE_URL)
-  DEPENDS:=kmod-ath10k
+$(Package/ath10k-firmware-default)
   TITLE:=ath10k firmware for QCA99x0 devices
 endef
 
+define Package/ath10k-firmware-qca6174
+$(Package/ath10k-firmware-default)
+  TITLE:=ath10k firmware for QCA6174 devices
+endef
+
 define Build/Compile
 
 endef
@@ -56,6 +61,11 @@ define Package/ath10k-firmware-qca988x/install
                $(1)/lib/firmware/ath10k/QCA988X/hw2.0/firmware-5.bin
 endef
 
+define Package/ath10k-firmware-qca6174/install
+       $(INSTALL_DIR) $(1)/lib/firmware/ath10k
+       $(CP) $(PKG_BUILD_DIR)/ath10k/QCA6174 $(1)/lib/firmware/ath10k/
+endef
+
 define Package/ath10k-firmware-qca99x0/install
        $(INSTALL_DIR) $(1)/lib/firmware/ath10k/QCA99X0/hw2.0
        $(INSTALL_DATA) \
@@ -68,3 +78,4 @@ endef
 
 $(eval $(call BuildPackage,ath10k-firmware-qca988x))
 $(eval $(call BuildPackage,ath10k-firmware-qca99x0))
+$(eval $(call BuildPackage,ath10k-firmware-qca6174))