don't compile libipkg in busybox if ipkg is disabled
authorFelix Fietkau <nbd@openwrt.org>
Sun, 4 Jun 2006 01:31:03 +0000 (01:31 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sun, 4 Jun 2006 01:31:03 +0000 (01:31 +0000)
SVN-Revision: 3901

openwrt/package/busybox/patches/911-ipkg.patch

index 7b6437c98ca4536e099fe606f2b7eb103d577fed..1d7a4e357461242e8cc1f6e9ce368fb67b15c903 100644 (file)
@@ -203,16 +203,16 @@ diff -ruN busybox-1.1.2-orig/archival/libipkg/Makefile.in busybox-1.1.2+ipkg-0.9
 +      str_util.c \
 +      xsystem.c \
 +
-+LIBIPKG-y += $(LIBIPKG_CORE_SOURCES)
-+LIBIPKG-y += $(LIBIPKG_CMD_SOURCES)
-+LIBIPKG-y += $(LIBIPKG_DB_SOURCES)
-+LIBIPKG-y += $(LIBIPKG_LIST_SOURCES)
-+LIBIPKG-y += $(LIBIPKG_UTIL_SOURCES)
++LIBIPKG-$(CONFIG_IPKG) += $(LIBIPKG_CORE_SOURCES)
++LIBIPKG-$(CONFIG_IPKG) += $(LIBIPKG_CMD_SOURCES)
++LIBIPKG-$(CONFIG_IPKG) += $(LIBIPKG_DB_SOURCES)
++LIBIPKG-$(CONFIG_IPKG) += $(LIBIPKG_LIST_SOURCES)
++LIBIPKG-$(CONFIG_IPKG) += $(LIBIPKG_UTIL_SOURCES)
 +LIBIPKG_OBJS=$(patsubst %.c,$(LIBIPKG_DIR)%.o, $(LIBIPKG-y))
 +
 +CFLAGS += -DIPKG_LIB -DIPKGLIBDIR="\"/usr/lib\"" -DHOST_CPU_STR="\"$(TARGET_ARCH)\""
 +
-+libraries-y += $(LIBIPKG_DIR)$(LIBIPKG_AR)
++libraries-$(CONFIG_IPKG) += $(LIBIPKG_DIR)$(LIBIPKG_AR)
 +
 +$(LIBIPKG_DIR)$(LIBIPKG_AR): $(LIBIPKG_OBJS)
 +      $(do_ar)