packages/baresip: use new service functions
authorNicolas Thill <nico@openwrt.org>
Wed, 16 Nov 2011 09:44:09 +0000 (09:44 +0000)
committerNicolas Thill <nico@openwrt.org>
Wed, 16 Nov 2011 09:44:09 +0000 (09:44 +0000)
SVN-Revision: 29171

net/baresip/Makefile
net/baresip/files/baresip.init

index 1340e4661df9b2b6074d3b0de5ad504660f4ef88..c389ab87ac0c68fba6a6560ad050aca28da2c393 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=baresip
 PKG_VERSION:=0.3.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.creytiv.com/pub/
index d0f5a24f81e26bed6074144dfe69326099ea26cf..e398595710108e9d44312018633ea0875431b934 100644 (file)
@@ -1,17 +1,14 @@
 #!/bin/sh /etc/rc.common
-#
 # Copyright (C) 2010-2011 OpenWrt.org
 # Copyright (C) 2010 Alfred E. Heggestad
 #
 
 START=92
-BIN=baresip
-OPTIONS=-d
 
 start() {
-       start-stop-daemon -S -q -x $BIN -- $OPTIONS
+       service_start /usr/bin/baresip -d
 }
 
 stop() {
-       start-stop-daemon -K -q -x $BIN
+       service_stop /usr/bin/baresip
 }