build: make initramfs kernel builds depend on the image prepare step
authorFelix Fietkau <nbd@openwrt.org>
Mon, 11 May 2015 09:07:58 +0000 (09:07 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Mon, 11 May 2015 09:07:58 +0000 (09:07 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 45671

include/image.mk

index 4161d60ded9a52907d1600b3fd68fc2c2626b10e..1b7fd2404aa2a8c6a904a14714585d2c3ae15423 100644 (file)
@@ -365,6 +365,7 @@ endef
 define Device/Build/initramfs
   $$(_TARGET): $(BIN_DIR)/$$(KERNEL_INITRAMFS_IMAGE)
 
+  $(KDIR)/$$(KERNEL_NAME)-initramfs: image_prepare
   $(BIN_DIR)/$$(KERNEL_INITRAMFS_IMAGE): $(KDIR)/$$(KERNEL_INITRAMFS_IMAGE)
        cp $$^ $$@