[package] update bind to 9.6.0-P1 (#4791)
authorFlorian Fainelli <florian@openwrt.org>
Sun, 26 Jul 2009 20:20:54 +0000 (20:20 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sun, 26 Jul 2009 20:20:54 +0000 (20:20 +0000)
SVN-Revision: 17024

net/bind/Makefile
net/bind/files/named.init
net/bind/patches/100-cross_compile.patch

index a5bad70a78614e111a9d40e2379c7239be0a8b59..d6cc4047eb52fb02a8f4e939b6d732f0b868e4de 100644 (file)
@@ -8,14 +8,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=bind
-PKG_VERSION:=9.5.0-P1
-PKG_RELEASE:=3
+PKG_VERSION:=9.6.0-P1
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:= \
        ftp://ftp.isc.org/isc/bind9/$(PKG_VERSION) \
        http://www.mirrorservice.org/sites/ftp.isc.org/isc/bind9/$(PKG_VERSION)
-PKG_MD5SUM:=a4f9dd6d205d24ec89fa4e44d8188197
+PKG_MD5SUM:=886b7eae55cfdc8cd8d2ca74a2f99c6e
 
 include $(INCLUDE_DIR)/package.mk
 
index 8188b185f24db6e150122a9a39b751ff1a75de56..a82fed9067d03ca1d3d473e48a64af87dcd5b883 100644 (file)
@@ -2,7 +2,7 @@
 START=50
 
 config_file=/etc/bind/named.conf
-pid_file=/var/run/named.pid
+pid_file=/var/run/named/named.pid
 
 start() {
   echo Starting isc-bind
index 47fd61bddb64f9320dd1d2f0096f0cf23bd4c45d..25af6848315889b9114728614205094b0247ddfa 100644 (file)
@@ -1,8 +1,18 @@
-Index: bind-9.5.0-P1/configure
+Index: bind-9.6.0-P1/configure
 ===================================================================
---- bind-9.5.0-P1.orig/configure       2008-05-06 02:33:33.000000000 +0100
-+++ bind-9.5.0-P1/configure    2008-07-12 08:23:25.000000000 +0100
-@@ -6369,8 +6369,7 @@
+--- bind-9.6.0-P1.orig/configure       2008-05-06 02:33:33.000000000 +0100
++++ bind-9.6.0-P1/configure    2008-07-12 08:23:25.000000000 +0100
+@@ -5449,8 +5449,7 @@
+   { { echo "$as_me:$LINENO: error: cannot run test program while cross compiling
+ See \`config.log' for more details." >&5
+ echo "$as_me: error: cannot run test program while cross compiling
+-See \`config.log' for more details." >&2;}
+-   { (exit 1); exit 1; }; }
++See \`config.log' for more details." >&2;} }
+ else
+   cat >conftest.$ac_ext <<_ACEOF
+ /* confdefs.h.  */
+@@ -6791,8 +6790,7 @@
  else
    test "$cross_compiling" = yes &&
    { { echo "$as_me:$LINENO: error: cannot check for file existence when cross compiling" >&5
@@ -12,7 +22,7 @@ Index: bind-9.5.0-P1/configure
  if test -r "$devrandom"; then
    eval "$as_ac_File=yes"
  else
-@@ -25119,195 +25118,6 @@
+@@ -25535,195 +25533,6 @@
  # which provides some (all?) of the desired functions.
  #
  
@@ -208,15 +218,3 @@ Index: bind-9.5.0-P1/configure
  #
  # Look for a 4.4BSD-style sa_len member in struct sockaddr.
  #
-Index: bind-9.5.0-P1/lib/bind/configure
-===================================================================
---- bind-9.5.0-P1.orig/lib/bind/configure      2008-04-29 00:51:46.000000000 +0100
-+++ bind-9.5.0-P1/lib/bind/configure   2008-06-08 15:16:17.000000000 +0100
-@@ -5292,6 +5292,7 @@
- if { as_var=$as_ac_File; eval "test \"\${$as_var+set}\" = set"; }; then
-   echo $ECHO_N "(cached) $ECHO_C" >&6
- else
-+cross_compiling=no
-   test "$cross_compiling" = yes &&
-   { { echo "$as_me:$LINENO: error: cannot check for file existence when cross compiling" >&5
- echo "$as_me: error: cannot check for file existence when cross compiling" >&2;}