[backfire] merge r24051
authorJo-Philipp Wich <jow@openwrt.org>
Sun, 21 Nov 2010 13:54:09 +0000 (13:54 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sun, 21 Nov 2010 13:54:09 +0000 (13:54 +0000)
SVN-Revision: 24052

package/dnsmasq/Makefile
package/dnsmasq/files/dnsmasq.init

index 695d26088bf453d27d039590e1ac9c56f2687d34..14d3cc4dd622308d9c165e08d1584cd14a029d46 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dnsmasq
 PKG_VERSION:=2.55
-PKG_RELEASE:=5
+PKG_RELEASE:=6
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://thekelleys.org.uk/dnsmasq
index 1e91eb2b5fb036a0e33a6f7417e1ab07dc89da93..0c2229d88b2ee40e3d69312f43dab908054bdf8a 100644 (file)
@@ -271,7 +271,7 @@ dhcp_add() {
                DNS_SERVERS="$DNS_SERVERS $dnsserver"
        }
 
-       append_bool "$cfg" ignore "-2 '$ifname'" && return 0
+       append_bool "$cfg" ignore "-2 $ifname" && return 0
 
        config_get proto "$net" proto
        [ static = "$proto" ] || return 0
@@ -283,7 +283,12 @@ dhcp_add() {
        #check for an already active dhcp server on the interface, unless 'force' is set
        config_get_bool force "$cfg" force 0
        [ $force -gt 0 ] || {
-               udhcpc -n -q -s /bin/true -t 1 -i $ifname >&- && return 0
+               udhcpc -n -q -s /bin/true -t 1 -i $ifname >&- && {
+                       logger -t dnsmasq \
+                               "found already running DHCP-server on interface '$ifname'" \
+                               "refusing to start, use 'option force 1' to override"
+                       return 0
+               }
        }
 
        config_get start "$cfg" start