[packages] miniupnpd: bump to v1.3, remove obsolete patches, link against libiptc.so
authorJo-Philipp Wich <jow@openwrt.org>
Sat, 2 May 2009 00:59:22 +0000 (00:59 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sat, 2 May 2009 00:59:22 +0000 (00:59 +0000)
SVN-Revision: 15551

net/miniupnpd/Makefile
net/miniupnpd/patches/001-makefile-tweaks.patch [deleted file]
net/miniupnpd/patches/100-iptables-wan-device-name.patch [deleted file]
net/miniupnpd/patches/101-config.h.openwrt.patch [deleted file]

index 161e02d325668dea3b70854c83dff4a5397611d1..9866674003bdc85c7193c03dee48cd6d7450c737 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,9 +8,9 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=miniupnpd
-PKG_VERSION:=1.1
-PKG_RELEASE:=5
-PKG_MD5SUM:=a0f6651476721db9b554668c8c83b151
+PKG_VERSION:=1.3
+PKG_RELEASE:=1
+PKG_MD5SUM:=b5e70e80dcf45b424b8fe3c966bdc613
 
 PKG_SOURCE_URL:=http://miniupnp.free.fr/files
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
@@ -30,8 +30,8 @@ define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) -f Makefile.openwrt \
                $(TARGET_CONFIGURE_OPTS) \
                STAGING_DIR="$(STAGING_DIR)" \
-               CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS)" \
-               LIBS="$(STAGING_DIR)/usr/lib/libiptc.a"
+               CFLAGS="$(TARGET_CFLAGS) -I $(STAGING_DIR)/usr/include -DIPTABLES_143" \
+               LIBS="$(STAGING_DIR)/usr/lib/libiptc.so"
 endef
 
 define Package/miniupnpd/install
diff --git a/net/miniupnpd/patches/001-makefile-tweaks.patch b/net/miniupnpd/patches/001-makefile-tweaks.patch
deleted file mode 100644 (file)
index 1af76c5..0000000
+++ /dev/null
@@ -1,35 +0,0 @@
-Index: Makefile.openwrt
-===================================================================
-RCS file: /usr/local/cvsroot/miniupnp/miniupnpd/Makefile.openwrt,v
-retrieving revision 1.11
-diff -u -r1.11 miniupnpd-1.1/Makefile.openwrt
---- miniupnpd-1.1.orig/Makefile.openwrt        29 Jan 2008 12:52:03 -0000      1.11
-+++ miniupnpd-1.1/Makefile.openwrt     1 May 2008 22:34:28 -0000
-@@ -6,7 +6,7 @@
- # your openwrt SDK/etc...
- # http://miniupnp.tuxfamily.org/forum/viewtopic.php?p=713
--include $(TOPDIR)/rules.mk
-+#include $(TOPDIR)/rules.mk
- #CFLAGS = -Wall -O -D_GNU_SOURCE -g
- #CFLAGS = -Wall -Os -D_GNU_SOURCE
- #CC = mipsel-linux-gcc
-@@ -16,7 +16,8 @@
- CP = cp
- RM = rm -f
- INSTALL = install
--IPTABLESINC=$(BUILD_DIR)/iptables-1.3.3/include
-+IPTABLESINC=$(STAGING_DIR)/usr/include
-+#IPTABLESINC=$(BUILD_DIR)/iptables-1.3.3/include
- #IPTABLESINC=$(TOPDIR)/../iptables-1.3.3/include
- BASEOBJS = miniupnpd.o upnphttp.o upnpdescgen.o upnpsoap.o \
-@@ -28,7 +29,7 @@
- NETFILTEROBJS = netfilter/iptcrdr.o
- ALLOBJS = $(BASEOBJS) $(LNXOBJS) $(NETFILTEROBJS)
--LIBS = $(BUILD_DIR)/iptables-1.3.3/libiptc/libiptc.a
-+#LIBS = $(BUILD_DIR)/iptables-1.3.3/libiptc/libiptc.a
- #LIBS = $(TOPDIR)/../iptables-1.3.3/libiptc/libiptc.a
- TESTUPNPDESCGENOBJS = testupnpdescgen.o upnpdescgen.o
diff --git a/net/miniupnpd/patches/100-iptables-wan-device-name.patch b/net/miniupnpd/patches/100-iptables-wan-device-name.patch
deleted file mode 100644 (file)
index cd87070..0000000
+++ /dev/null
@@ -1,36 +0,0 @@
-Index: miniupnpd-1.1/netfilter/iptables_init.sh
-===================================================================
---- miniupnpd-1.1.orig/netfilter/iptables_init.sh      2007-09-17 17:43:54.000000000 -0500
-+++ miniupnpd-1.1/netfilter/iptables_init.sh   2007-09-17 17:43:54.000000000 -0500
-@@ -1,9 +1,12 @@
- #! /bin/sh
- # $Id: iptables_init.sh,v 1.3 2006/11/23 12:32:57 nanard Exp $
-+. /etc/functions.sh
- IPTABLES=iptables
- #change this parameters :
--EXTIF=eth0
-+include /lib/network
-+scan_interfaces
-+config_get EXTIF wan ifname
- EXTIP="`LC_ALL=C /sbin/ifconfig $EXTIF | grep 'inet addr' | awk '{print $2}' | sed -e 's/.*://'`"
- echo "External IP = $EXTIP"
-Index: miniupnpd-1.1/netfilter/iptables_removeall.sh
-===================================================================
---- miniupnpd-1.1.orig/netfilter/iptables_removeall.sh 2007-09-17 17:43:54.000000000 -0500
-+++ miniupnpd-1.1/netfilter/iptables_removeall.sh      2007-09-17 17:43:54.000000000 -0500
-@@ -1,9 +1,12 @@
- #! /bin/sh
- # $Id: iptables_removeall.sh,v 1.3 2006/11/23 12:32:57 nanard Exp $
-+. /etc/functions.sh
- IPTABLES=iptables
- #change this parameters :
--EXTIF=eth0
-+include /lib/network
-+scan_interfaces
-+config_get EXTIF wan ifname
- EXTIP="`LC_ALL=C /sbin/ifconfig $EXTIF | grep 'inet addr' | awk '{print $2}' | sed -e 's/.*://'`"
- #removing the MINIUPNPD chain for nat
diff --git a/net/miniupnpd/patches/101-config.h.openwrt.patch b/net/miniupnpd/patches/101-config.h.openwrt.patch
deleted file mode 100644 (file)
index 703821d..0000000
+++ /dev/null
@@ -1,38 +0,0 @@
-Index: miniupnpd-1.1/config.h.openwrt
-===================================================================
-RCS file: /usr/local/cvsroot/miniupnp/miniupnpd/miniupnpd-1.1/config.h.openwrt,v
-retrieving revision 1.2
-diff -u -r1.2 miniupnpd-1.1/config.h.openwrt
---- miniupnpd-1.1/config.h.openwrt     26 Apr 2007 19:11:09 -0000      1.2
-+++ miniupnpd-1.1/config.h.openwrt     1 May 2008 22:47:17 -0000
-@@ -1,18 +1,27 @@
- /* $Id: miniupnpd-1.1/config.h.openwrt,v 1.2 2007/04/26 19:11:09 nanard Exp $ */
- /* MiniUPnP Project
-  * http:///miniupnp.free.fr
-- * (c) 2006 Thomas Bernard
-+ * (c) 2006-2008 Thomas Bernard
-  */
- #ifndef __CONFIG_H__
- #define __CONFIG_H__
- #define UPNP_VERSION  "20070228"
--
-+#define USE_NETFILTER 1
- #define OS_NAME       "OpenWRT"
- /* OS/version */
--#define OS_VERSION    "OpenWRT/WhiteRussian"
-+#define OS_VERSION    "OpenWRT/kamikaze"
- #define OS_URL        "http://openwrt.org/"
- #define LOG_MINIUPNPD LOG_DAEMON
-+
-+/* Comment the following line to disable NAT-PMP operations */
-+#define ENABLE_NATPMP
-+
-+/* Comment the following line to use home made daemonize() func instead
-+ * of BSD daemon() */
-+#define USE_DAEMON
-+
-+#define ENABLE_L3F_SERVICE
- #endif