[package] ppp: enable multilink support (#4837)
authorJo-Philipp Wich <jow@openwrt.org>
Mon, 22 Feb 2010 02:26:32 +0000 (02:26 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Mon, 22 Feb 2010 02:26:32 +0000 (02:26 +0000)
SVN-Revision: 19811

package/ppp/patches/200-makefile.patch
target/linux/at91/config-2.6.25
target/linux/generic-2.4/config-default

index e9731d1..af82674 100644 (file)
@@ -1,6 +1,6 @@
 --- a/pppd/Makefile.linux
 +++ b/pppd/Makefile.linux
-@@ -48,21 +48,21 @@ MPPE=y
+@@ -48,7 +48,7 @@ MPPE=y
  # Uncomment the next line to include support for PPP packet filtering.
  # This requires that the libpcap library and headers be installed
  # and that the kernel driver support PPP packet filtering.
@@ -9,10 +9,7 @@
  
  # Uncomment the next line to enable multilink PPP (enabled by default)
  # Linux distributions: Please leave multilink ENABLED in your builds
- # of pppd!
--HAVE_MULTILINK=y
-+#HAVE_MULTILINK=y
+@@ -58,11 +58,11 @@ HAVE_MULTILINK=y
  # Uncomment the next line to enable the TDB database (enabled by default.)
  # If you enable multilink, then TDB is automatically enabled also.
  # Linux distributions: Please leave TDB ENABLED in your builds.
index 196f2d1..572d596 100644 (file)
@@ -133,10 +133,6 @@ CONFIG_MTD_CMDLINE_PARTS=y
 # CONFIG_PCI is not set
 # CONFIG_PCI_SYSCALL is not set
 CONFIG_PHYLIB=y
-# CONFIG_PPP_MULTILINK is not set
-# CONFIG_PPPOATM is not set
-# CONFIG_PPPOL2TP is not set
-# CONFIG_PPP_SYNC_TTY is not set
 # CONFIG_SCSI_WAIT_SCAN is not set
 # CONFIG_SDIO_UART is not set
 # CONFIG_SERIAL_8250 is not set
index 5dce427..8490f36 100644 (file)
@@ -595,7 +595,7 @@ CONFIG_PPP_DEFLATE=m
 CONFIG_PPP_FILTER=y
 CONFIG_PPP=m
 CONFIG_PPP_MPPE_MPPC=m
-# CONFIG_PPP_MULTILINK is not set
+CONFIG_PPP_MULTILINK=y
 CONFIG_PPPOE=m
 CONFIG_PPP_SYNC_TTY=m
 # CONFIG_PRISM54 is not set