kernel: fix the pcspkr module, add proper dependencies, add the actual sound module
authorFelix Fietkau <nbd@openwrt.org>
Thu, 25 Oct 2012 15:13:11 +0000 (15:13 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Thu, 25 Oct 2012 15:13:11 +0000 (15:13 +0000)
Backport of r33921

SVN-Revision: 33926

package/kernel/modules/sound.mk

index 4ccdc8b80626733d0e15e7fb10fc0f29dabe3926..3d12ba650ffaaa9f86a6339efc80593042c624d0 100644 (file)
@@ -7,21 +7,6 @@
 
 SOUND_MENU:=Sound Support
 
-define KernelPackage/pcspkr
-  SUBMENU:=$(SOUND_MENU)
-  TITLE:=PC speaker support
-  KCONFIG:=CONFIG_INPUT_PCSPKR
-  FILES:=$(LINUX_DIR)/drivers/input/misc/pcspkr.ko
-  AUTOLOAD:=$(call AutoLoad,50,pcspkr)
-endef
-
-define KernelPackage/pcspkr/description
- This enables sounds (tones) through the pc speaker
-endef
-
-$(eval $(call KernelPackage,pcspkr))
-
-
 # allow targets to override the soundcore stuff
 SOUNDCORE_LOAD ?= \
        soundcore \
@@ -201,3 +186,24 @@ define KernelPackage/sound-soc-gw_avila
 endef
 
 $(eval $(call KernelPackage,sound-soc-gw_avila))
+
+
+define KernelPackage/pcspkr
+  DEPENDS:=@!TARGET_x86
+  TITLE:=PC speaker support
+  KCONFIG:= \
+       CONFIG_INPUT_PCSPKR \
+       CONFIG_SND_PCSP
+  FILES:= \
+       $(LINUX_DIR)/drivers/input/misc/pcspkr.ko \
+       $(LINUX_DIR)/sound/drivers/pcsp/snd-pcsp.ko
+  AUTOLOAD:=$(call AutoLoad,50,pcspkr snd-pcsp)
+  $(call AddDepends/input)
+  $(call AddDepends/sound)
+endef
+
+define KernelPackage/pcspkr/description
+ This enables sounds (tones) through the pc speaker
+endef
+
+$(eval $(call KernelPackage,pcspkr))