[package] update vpnc to 0.5.3 (#5648)
authorFlorian Fainelli <florian@openwrt.org>
Sun, 9 Aug 2009 10:33:55 +0000 (10:33 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sun, 9 Aug 2009 10:33:55 +0000 (10:33 +0000)
SVN-Revision: 17192

net/vpnc/Makefile
net/vpnc/patches/001-cross.patch
net/vpnc/patches/002-vpn_script.patch
net/vpnc/patches/003-no_makeman.patch

index 1703e12c3864dd818c02c1923aef89c11ccbe7c3..0b9d07e7aa7a85d73acb3efed2a4880a37c4f9ae 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=vpnc
-PKG_VERSION:=0.5.1
+PKG_VERSION:=0.5.3
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.unix-ag.uni-kl.de/~massar/vpnc/
-PKG_MD5SUM:=7a8e94dbe94f39a4fd89b72e0125f66f
+PKG_MD5SUM:=4378f9551d5b077e1770bbe09995afb3
 
 include $(INCLUDE_DIR)/package.mk
 
index f778b40133fff0ab3e169b9ac74a64121eecfcc8..fda17b168a761c1a72b036a3a292cbe6498d30b7 100644 (file)
@@ -1,7 +1,7 @@
 --- a/Makefile
 +++ b/Makefile
 @@ -20,7 +20,7 @@
- # $Id: Makefile 236 2007-09-05 20:40:59Z Joerg Mayer $
+ # $Id: Makefile 312 2008-06-15 18:09:42Z Joerg Mayer $
  
  DESTDIR=
 -PREFIX=/usr/local
@@ -9,7 +9,7 @@
  ETCDIR=/etc/vpnc
  BINDIR=$(PREFIX)/bin
  SBINDIR=$(PREFIX)/sbin
-@@ -50,14 +50,11 @@
+@@ -51,14 +51,11 @@ RELEASE_VERSION := $(shell cat VERSION)
  #OPENSSLLIBS = -lcrypto
  
  CC=gcc
index 53fd726e86e7d84a411739bf5e7933707915c192..5a0ebce6416aef66ad587b2e575e304544ebe730 100644 (file)
@@ -1,16 +1,16 @@
---- a/vpnc-script
-+++ b/vpnc-script
-@@ -95,7 +95,7 @@
- # =========== tunnel interface handling ====================================
+--- a/vpnc-script.in
++++ b/vpnc-script.in
+@@ -97,7 +97,7 @@ do_ifconfig() {
+       fi
  
- do_ifconfig() {
--      ifconfig "$TUNDEV" inet "$INTERNAL_IP4_ADDRESS" $ifconfig_syntax_ptp "$INTERNAL_IP4_ADDRESS" netmask 255.255.255.255 mtu 1412 up
-+      ifconfig "$TUNDEV" "$INTERNAL_IP4_ADDRESS" $ifconfig_syntax_ptp "$INTERNAL_IP4_ADDRESS" netmask 255.255.255.255 mtu 1412 up
- }
+       # Point to point interface require a netmask of 255.255.255.255 on some systems
+-      ifconfig "$TUNDEV" inet "$INTERNAL_IP4_ADDRESS" $ifconfig_syntax_ptp "$INTERNAL_IP4_ADDRESS" netmask 255.255.255.255 mtu ${MTU} up
++      ifconfig "$TUNDEV" "$INTERNAL_IP4_ADDRESS" $ifconfig_syntax_ptp "$INTERNAL_IP4_ADDRESS" netmask 255.255.255.255 mtu ${MTU} up
  
- destroy_tun_device() {
-@@ -490,6 +490,18 @@
-       fi
+       if [ -n "$INTERNAL_IP4_NETMASK" ]; then
+               set_network_route $INTERNAL_IP4_NETADDR $INTERNAL_IP4_NETMASK $INTERNAL_IP4_NETMASKLEN
+@@ -503,6 +503,18 @@ do_disconnect() {
+       destroy_tun_device
  }
  
 +start_vpn_nat() {
@@ -28,7 +28,7 @@
  #### Main
  
  if [ -z "$reason" ]; then
-@@ -503,8 +515,10 @@
+@@ -516,8 +528,10 @@ case "$reason" in
                ;;
        connect)
                do_connect
index e92ffeaee9e7ad4dd9b8946af94545903d5ac839..ef0164355079c8ca3a39f9bb3af516700f24723e 100644 (file)
@@ -1,12 +1,11 @@
-diff -urN vpnc-0.5.1/Makefile vpnc-0.5.1.new/Makefile
---- vpnc-0.5.1/Makefile        2007-09-06 22:05:15.000000000 +0200
-+++ vpnc-0.5.1.new/Makefile    2008-07-05 15:30:04.000000000 +0200
-@@ -71,7 +71,7 @@
+--- a/Makefile
++++ b/Makefile
+@@ -69,7 +69,7 @@ vpnc : $(OBJS) vpnc.o
        $(CC) -o $@ $^ $(LDFLAGS)
  
  vpnc.8 : vpnc.8.template makeman.pl vpnc
 -      ./makeman.pl
 +      touch vpnc.8
  
- cisco-decrypt : cisco-decrypt.o config.o supp.o sysdep.o vpnc-debug.o
-       $(CC) -o $@ $^ $(LDFLAGS)
+ vpnc-script : vpnc-script.in
+       sed -e 's,@''PREFIX''@,$(PREFIX),g' $< > $@ && chmod 755 $@