[backfire/packages] pyserial: merge [28431]
authorNicolas Thill <nico@openwrt.org>
Thu, 13 Oct 2011 11:13:28 +0000 (11:13 +0000)
committerNicolas Thill <nico@openwrt.org>
Thu, 13 Oct 2011 11:13:28 +0000 (11:13 +0000)
SVN-Revision: 28432

lang/pyserial/Makefile

index dceb461c463e735e087754fe310eb061292b82ca..aed691956ba28958ff178d6dc94ef70b693659a4 100644 (file)
@@ -1,5 +1,5 @@
 #
 #
-# Copyright (C) 2008 OpenWrt.org
+# Copyright (C) 2008-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -34,14 +34,16 @@ define Package/pyserial/description
 endef
 
 define Build/Compile
 endef
 
 define Build/Compile
-       $(call Build/Compile/PyMod,,install --prefix="$(PKG_INSTALL_DIR)/usr")
+       $(call Build/Compile/PyMod,., \
+               install --prefix="/usr" --root="$(PKG_INSTALL_DIR)", \
+       )
 endef
 
 define Package/pyserial/install
        $(INSTALL_DIR) $(1)$(PYTHON_PKG_DIR)
        $(CP) \
            $(PKG_INSTALL_DIR)$(PYTHON_PKG_DIR)/* \
 endef
 
 define Package/pyserial/install
        $(INSTALL_DIR) $(1)$(PYTHON_PKG_DIR)
        $(CP) \
            $(PKG_INSTALL_DIR)$(PYTHON_PKG_DIR)/* \
-           $(1)$(PYTHON_PKG_DIR)
+           $(1)$(PYTHON_PKG_DIR)/
 endef
 
 $(eval $(call BuildPackage,pyserial))
 endef
 
 $(eval $(call BuildPackage,pyserial))