fix kernel version detection in switch driver
authorFelix Fietkau <nbd@openwrt.org>
Sun, 25 Dec 2005 21:57:14 +0000 (21:57 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sun, 25 Dec 2005 21:57:14 +0000 (21:57 +0000)
SVN-Revision: 2782

openwrt/target/linux/package/switch/src/Makefile
openwrt/target/linux/package/switch/src/switch-core.h

index e4b2b7f38bdbbd0bd2fb77cd1ea062209f7654cb..4c5f911ea28fd29a5886be4806656993cb6df15e 100644 (file)
@@ -11,8 +11,9 @@
 #
 
 obj-m  := switch-core.o switch-adm.o switch-robo.o
-export-objs := switch-core.o
 
 ifeq ($(MAKING_MODULES),1)
+export-objs := switch-core.o
+
 -include $(TOPDIR)/Rules.make
 endif
index c878d47868909e596add44a9ac9fb9ef10bc31c3..9927e851922d78b8d96879a762d2f457bdf3a9a4 100644 (file)
@@ -1,6 +1,7 @@
 #ifndef __SWITCH_CORE_H
 #define __SWITCH_CORE_H
 
+#include <linux/version.h>
 #include <linux/list.h>
 #define SWITCH_MAX_BUFSZ       4096
 
@@ -8,6 +9,14 @@
 #define SWITCH_MEDIA_100       2
 #define SWITCH_MEDIA_FD                4
 
+#ifndef KERNEL_VERSION
+#define KERNEL_VERSION(a,b,c) (((a) << 16) + ((b) << 8) + (c))
+#endif
+
+#if LINUX_VERSION_CODE < KERNEL_VERSION(2,5,0)
+#define LINUX_2_4
+#endif
+
 typedef int (*switch_handler)(char *buf, int nr);
 
 typedef struct {