yaddns: bump to 1.1
authorJohn Crispin <john@openwrt.org>
Wed, 30 Nov 2011 12:44:37 +0000 (12:44 +0000)
committerJohn Crispin <john@openwrt.org>
Wed, 30 Nov 2011 12:44:37 +0000 (12:44 +0000)
Changes compared to 1.0 are:

* autotools refactoring
* fix blocked state in request if connect() or recv() failed. Add timeout feature which abort pending request (connect(), send(), recv()) after XX seconds.
* add new ./configure options:
* --enable-debug
* --enable-log-debug
* --enable-log-color
* fix segfault case if user remove account cfg and SIGHUP yaddns when doing update procedure for the removed account.
* fix buffer overread in base64_encode function
* implement unit tests
* add -L, --use-syslog option

Signed-off-by: Anthony Viallard <avd@patatrac.info
SVN-Revision: 29362

net/yaddns/Makefile

index 8f55694ffce859a6c1fa75e10a40e30dfc53ffe5..612d951050db0bdfdaf9ae7828c6e4a94bb8522a 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=yaddns
-PKG_VERSION:=1.1-rc2
+PKG_VERSION:=1.1
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://download.gna.org/yaddns/
-PKG_MD5SUM:=919a25bd66abf926e049f3afea619e19
+PKG_MD5SUM:=d8b6ed9bed61dabaa17188d831e352d1
 
 PKG_INSTALL:=1