[packages] ffmpeg: add an option to enable/disable IPv6 support (closes: #4318)
authorNicolas Thill <nico@openwrt.org>
Wed, 25 Mar 2009 15:42:12 +0000 (15:42 +0000)
committerNicolas Thill <nico@openwrt.org>
Wed, 25 Mar 2009 15:42:12 +0000 (15:42 +0000)
SVN-Revision: 15040

multimedia/ffmpeg/Config.in
multimedia/ffmpeg/Makefile

index 6750233a1dfee3128930a7170cddda646a021d06..259cb8f4a80f66d4aae1be9462e91fe3ed5197b2 100644 (file)
@@ -259,3 +259,7 @@ config FFMPEG_PROTOCOL_udp
        bool
        prompt "udp:"
 
        bool
        prompt "udp:"
 
+config FFMPEG_PROTOCOL_IPv6
+       bool
+       prompt "IPv6"
+
index eef635baac0ea1cdb1fdda5298ac838665645080..524758a6d25d7bc06c514b3e11603dcff18185cb 100644 (file)
@@ -177,6 +177,13 @@ FFMPEG_CONFIGURE_PROTOCOLS:= \
                $(if $(CONFIG_FFMPEG_PROTOCOL_$(c)),--enable-protocol="$(c)") \
        )
 
                $(if $(CONFIG_FFMPEG_PROTOCOL_$(c)),--enable-protocol="$(c)") \
        )
 
+ifneq ($(CONFIG_FFMPEG_PROTOCOL_IPv6),)
+       FFMPEG_CONFIGURE_IPv6:= --enable-ipv6
+else
+       FFMPEG_CONFIGURE_IPv6:= --disable-ipv6
+endif
+
+
 define Build/Configure
        # this is *NOT* GNU configure
        ( cd $(PKG_BUILD_DIR); \
 define Build/Configure
        # this is *NOT* GNU configure
        ( cd $(PKG_BUILD_DIR); \
@@ -193,7 +200,6 @@ define Build/Configure
                --enable-ffmpeg \
                --enable-ffserver \
                --enable-gpl \
                --enable-ffmpeg \
                --enable-ffserver \
                --enable-gpl \
-               --disable-ipv6 \
                --enable-libfaad \
                --enable-pthreads \
                --disable-optimizations \
                --enable-libfaad \
                --enable-pthreads \
                --disable-optimizations \
@@ -216,6 +222,7 @@ define Build/Configure
                --disable-bsfs \
                --disable-protocols \
                $(FFMPEG_CONFIGURE_PROTOCOLS) \
                --disable-bsfs \
                --disable-protocols \
                $(FFMPEG_CONFIGURE_PROTOCOLS) \
+               $(FFMPEG_CONFIGURE_IPv6) \
        )
 endef
 
        )
 endef