[packages] radvd: allow uppercase chars in string literals (#12174)
authorJo-Philipp Wich <jow@openwrt.org>
Wed, 12 Sep 2012 09:42:44 +0000 (09:42 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Wed, 12 Sep 2012 09:42:44 +0000 (09:42 +0000)
SVN-Revision: 33377

ipv6/radvd/Makefile
ipv6/radvd/files/radvd.init

index 076a056b28200108238fbc9e0d75380099e6435e..571d9dee05b139b76b6882afc0fe495b837cb9ab 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=radvd
 PKG_VERSION:=1.9.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://v6web.litech.org/radvd/dist \
index 81e9001c33077213051f6a77b9c00e982ea99f09..8311c35e189f7658932c3b3e6c7e89f1c01899db 100644 (file)
@@ -39,7 +39,7 @@ validate_ip6prefix() {
 
 validate_radvd_string() {
        local radvd_string=$1
-       [ -z "$radvd_string" -o "$radvd_string" != "${radvd_string%%[!a-z0-9.:_-]*}" ] && return 1
+       [ -z "$radvd_string" -o "$radvd_string" != "${radvd_string%%[!A-Za-z0-9.:_-]*}" ] && return 1
        return 0
 }