ar71xx: build image for TL-WR710N v2.1
authorJohn Crispin <john@openwrt.org>
Fri, 11 Dec 2015 15:05:20 +0000 (15:05 +0000)
committerJohn Crispin <john@openwrt.org>
Fri, 11 Dec 2015 15:05:20 +0000 (15:05 +0000)
This patch just extends target/linux/ar71xx/image/Makefile to build
images also for version 2.1 of TL-WR710N
patch against the latest git

Signed off by: Norbert Wegener <nw@wegener-net.de>

SVN-Revision: 47849

target/linux/ar71xx/image/Makefile

index 5737005a48d614185878fb434cde192b691940f8..78be34514c20308260a91d7db68d817326790bd9 100644 (file)
@@ -596,6 +596,15 @@ define Device/tl-wr710n-v2
     CONSOLE := ttyATH0,115200
 endef
 
+define Device/tl-wr710n-v2.1
+    $(Device/tplink-8mlzma)
+    BOARDNAME := TL-WR710N
+    DEVICE_PROFILE := TLWR710
+    TPLINK_HWID := 0x07100002
+    TPLINK_HWREV := 0x00000002
+    CONSOLE := ttyATH0,115200
+endef
+
 define Device/tl-wr720n-v3
     $(Device/tplink-4mlzma)
     BOARDNAME := TL-WR720N-v3
@@ -611,7 +620,7 @@ define Device/tl-wr720n-v4
     TPLINK_HWID := 0x07200104
     CONSOLE := ttyATH0,115200
 endef
-TARGET_DEVICES += tl-wr703n-v1 tl-wr710n-v1 tl-wr710n-v2 tl-wr720n-v3 tl-wr720n-v4
+TARGET_DEVICES += tl-wr703n-v1 tl-wr710n-v1 tl-wr710n-v2 tl-wr710n-v2.1 tl-wr720n-v3 tl-wr720n-v4
 
 define Device/tl-wr740n-v1
     $(Device/tplink-4m)