[package] update hiawatha to 6.18 (#6231)
authorFlorian Fainelli <florian@openwrt.org>
Thu, 26 Nov 2009 23:39:24 +0000 (23:39 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Thu, 26 Nov 2009 23:39:24 +0000 (23:39 +0000)
SVN-Revision: 18552

net/hiawatha/Makefile
net/hiawatha/files/httpd.conf [deleted file]
net/hiawatha/files/mimetype.conf [deleted file]

index 374554fb5cc7455773f69c7b4ae6d7fc95218ca1..e79e6593679d371309716f4002803460fa7e6458 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=hiawatha
-PKG_VERSION:=6.15
-PKG_RELEASE:=2
+PKG_VERSION:=6.18
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.hiawatha-webserver.org/files/
-PKG_MD5SUM:=d0864612a68ba3c0251a721f8ba911a5
+PKG_MD5SUM:=cd923b80db84c6e9f356dad3343ba3f5
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -35,10 +35,11 @@ CONFIGURE_ARGS+= \
        --disable-ssl
 
 CONFIGURE_VARS+= \
-       ac_cv_file__dev_urandom=yes
+       ac_cv_file__dev_urandom=yes \
+       webrootdir=/www
 
 define Package/hiawatha/conffiles
-/etc/hiawatha/httpd.conf
+/etc/hiawatha/hiawatha.conf
 /etc/hiawatha/mimetype.conf
 endef
 
@@ -46,8 +47,7 @@ define Package/hiawatha/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/hiawatha $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/etc/hiawatha
-       $(INSTALL_DATA) ./files/httpd.conf $(1)/etc/hiawatha/
-       $(INSTALL_DATA) ./files/mimetype.conf $(1)/etc/hiawatha/
+       $(INSTALL_CONF) $(PKG_BUILD_DIR)/etc/hiawatha/{hiawatha,mimetype}.conf $(1)/etc/hiawatha/
 endef
 
 $(eval $(call BuildPackage,hiawatha))
diff --git a/net/hiawatha/files/httpd.conf b/net/hiawatha/files/httpd.conf
deleted file mode 100644 (file)
index 4bf6755..0000000
+++ /dev/null
@@ -1,115 +0,0 @@
-# Hiawatha main configuration file
-#
-
-
-# GENERAL SETTINGS
-#
-#ServerId = www-data
-ConnectionsTotal = 150
-ConnectionsPerIP = 10
-SystemLogfile = /var/log/hiawatha/system.log
-GarbageLogfile = /var/log/hiawatha/garbage.log
-
-
-# BINDING SETTINGS
-# A binding is where a client can connect to.
-#
-Binding {
-       Port = 80
-#      Interface = 127.0.0.1
-#      MaxKeepAlive = 30
-#      TimeForRequest = 3,20
-}
-#
-#Binding {
-#      Port = 443
-#      Interface = ::1
-#      MaxKeepAlive = 30
-#      TimeForRequest = 3,20
-#      ServerKey = hiawatha.pem
-#      UseSSL = yes
-#}
-
-
-# BANNING SETTINGS
-# Deny service to clients who misbehave.
-#
-#BanOnGarbage = 300
-#BanOnMaxPerIP = 60
-#BanOnMaxReqSize = 300
-#KickOnBan = yes
-#RebanDuringBan = yes
-
-
-# COMMON GATEWAY INTERFACE (CGI) SETTINGS
-# These settings can be used to run CGI applications. Use the 'php-fcgi'
-# tool to start PHP as a FastCGI daemon.
-#
-#CGIhandler = /usr/bin/php-cgi:php
-#CGIhandler = /usr/bin/perl:pl
-#CGIhandler = /usr/bin/python:py
-#CGIextension = cgi
-#
-#FastCGIserver {
-#      FastCGIid = PHP4
-#      ConnectTo = 127.0.0.1:2004
-#      Extension = php, php4
-#}
-#
-#FastCGIserver {
-#      FastCGIid = PHP5
-#      ConnectTo = 10.0.0.100:2005, 10.0.0.101:2005
-#      Extension = php, php5
-#      SessionTimeout = 30
-#}
-
-
-# URL TOOLKIT
-# These URL toolkit rules are made for the Skeleton PHP framework,
-# which can be downloaded from: http://skeleton.leisink.org/
-#
-#UrlToolkit {
-#      ToolkitID = skeleton
-#      Match ^/$ Return
-#      RequestURI isfile Exit
-#      Match (.*)\?(.*) Rewrite $1&$2
-#      Match /(.*) Rewrite /index.php?page=$1
-#}
-
-
-# DEFAULT WEBSITE
-# It is wise to use your IP address as the hostname of the default website
-# and give it a blank webpage. By doing so, automated webscanners won't find
-# your possible vulnerable website.
-#
-Hostname = 127.0.0.1
-WebsiteRoot = /www
-StartFile = index.html
-AccessLogfile = /var/log/hiawatha/access.log
-ErrorLogfile = /var/log/hiawatha/error.log
-#ErrorHandler = 404:/error.cgi
-
-
-# VIRTUAL HOSTS
-# Use a VirtualHost section to declare the websites you want to host.
-#
-#VirtualHost {
-#      Hostname = www.my-domain.com
-#      WebsiteRoot = /var/www/my-domain/public
-#      StartFile = index.php
-#      AccessLogfile = /var/www/my-domain/log/access.log
-#      ErrorLogfile = /var/www/my-domain/log/error.log
-#      ExecuteCGI = yes
-#      FastCGI = PHP4
-#      TimeForCGI = 5
-#}
-
-
-# DIRECTORY SETTINGS
-# You can specify some settings per directory.
-#
-#Directory {
-#      Path = /home/baduser
-#      ExecuteCGI = no
-#      UploadSpeed = 10,2
-#}
diff --git a/net/hiawatha/files/mimetype.conf b/net/hiawatha/files/mimetype.conf
deleted file mode 100644 (file)
index 7e876c7..0000000
+++ /dev/null
@@ -1,16 +0,0 @@
-application/pdf                                                pdf
-application/octet-stream                       class
-application/x-ns-proxy-autoconfig      pac
-application/x-shockwave-flash          swf
-audio/x-wav                                                    wav
-image/gif                                                      gif
-image/jpeg                                                     jpg
-image/jpeg                                                     jpeg
-image/png                                                      png
-text/css                                                       css
-text/html                                                      html
-text/html                                                      htm
-text/javascript                                                js
-text/plain                                                     txt
-text/xml                                                       dtd
-text/xml                                                       xml