make lzo and server support in openvpn optional
authorFelix Fietkau <nbd@openwrt.org>
Sun, 3 Apr 2005 21:36:01 +0000 (21:36 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sun, 3 Apr 2005 21:36:01 +0000 (21:36 +0000)
SVN-Revision: 551

openwrt/package/Makefile
openwrt/package/openvpn/Config.in
openwrt/package/openvpn/Makefile
openwrt/scripts/configtest.pl

index 9804dedee4dee465d091ee877dbf5805def4478c..bb378848ff9381d3fff8e7271ba9060ecfd4e978 100644 (file)
@@ -54,6 +54,10 @@ clean: $(patsubst %,%-clean,$(package-) $(package-y) $(package-m)) linux-clean
 compile: $(patsubst %,%-compile,$(package-y) $(package-m))
 install: $(patsubst %,%-install,$(package-y))
 
+ifeq ($(BR2_PACKAGE_OPENVPN_LZO),y)
+openvpn-compile: lzo-compile
+endif
+
 nocatsplash-compile: glib-compile
 arpwatch-compile: libpcap-compile
 tcpdump-compile: libpcap-compile
index 442313fff6ebe0e57f108d6da235a6fd3d77a667..873e61b9d4066cf99c2eee61cfb395b43a190f69 100644 (file)
@@ -3,8 +3,18 @@ config BR2_PACKAGE_OPENVPN
        default m
        select BR2_PACKAGE_KMOD_TUN
        select BR2_PACKAGE_OPENSSL
-       select BR2_PACKAGE_LZO
        help
          Open Source VPN solution using SSL
 
          http://openvpn.net/
+
+config BR2_PACKAGE_OPENVPN_SERVER
+       bool "Enable server support"
+       default y
+       depends BR2_PACKAGE_OPENVPN
+
+config BR2_PACKAGE_OPENVPN_LZO
+       bool "Enable transparent compression (lzo)"
+       default y
+       depends BR2_PACKAGE_OPENVPN
+       select BR2_PACKAGE_LZO
index bab2528906f4f44ec61e4c5560939d7d4bb77a1c..991e52f9e124a1ba7c2f6bc38c87c4bb0d924db9 100644 (file)
@@ -14,6 +14,14 @@ PKG_CAT:=zcat
 PKG_IPK:=$(PACKAGE_DIR)/$(PKG_NAME)_$(PKG_VERSION)-$(PKG_RELEASE)_$(ARCH).ipk
 PKG_IPK_DIR:=$(PKG_BUILD_DIR)/ipkg
 
+ifneq ($(BR2_PACKAGE_OPENVPN_LZO),y)
+DISABLE_LZO:=--disable-lzo
+endif
+
+ifneq ($(BR2_PACKAGE_OPENVPN_SERVER),y)
+DISABLE_SERVER:=--disable-server
+endif
+
 $(DL_DIR)/$(PKG_SOURCE):
         $(SCRIPT_DIR)/download.pl $(DL_DIR) $(PKG_SOURCE) $(PKG_MD5SUM) $(PKG_SOURCE_URL)
 
@@ -46,6 +54,8 @@ $(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.unpacked
                --disable-management \
                --disable-socks \
                --disable-http \
+               $(DISABLE_LZO) \
+               $(DISABLE_SERVER) \
        );
        touch $(PKG_BUILD_DIR)/.configured
 
index 05022debd379f59356c626f869e9b588a3e53977..3ca33d86c55f5cce306d012dbccdbe3eb52d883f 100755 (executable)
@@ -1,6 +1,7 @@
 #!/usr/bin/perl
 my %change = (
        'BUSYBOX' => 'make -C package busybox-clean',
+       'OPENVPN_' => 'make -C package openvpn-clean',
        '' => 'make target_clean'
 );