[uci] Create $(1)/etc/uci-defaults directory during installation. Thanks Yuji Mano.
authorAndy Boyett <agb@openwrt.org>
Tue, 17 Jun 2008 00:44:10 +0000 (00:44 +0000)
committerAndy Boyett <agb@openwrt.org>
Tue, 17 Jun 2008 00:44:10 +0000 (00:44 +0000)
 - Fixes the use of CONFIG_UCI_PRECONFIG under git; git does not track empty directories.

SVN-Revision: 11517

package/uci/Makefile

index ecc53b0890b89d5a1e84192e25044431d23a8479..6bf2a13b63382f40afb7ee69b4809cf402ad8f46 100644 (file)
@@ -78,6 +78,7 @@ define Package/libuci-lua/install
 endef
 
 define Package/uci/install
+       $(INSTALL_DIR) $(1)/etc/uci-defaults
        $(INSTALL_DIR) $(1)/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/uci $(1)/sbin/
        $(CP) ./files/uci/* $(1)/