kernel: update linux 3.7 to 3.7.10
authorGabor Juhos <juhosg@openwrt.org>
Sun, 3 Mar 2013 13:57:40 +0000 (13:57 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Sun, 3 Mar 2013 13:57:40 +0000 (13:57 +0000)
Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
SVN-Revision: 35860

18 files changed:
include/kernel-version.mk
target/linux/adm5120/Makefile
target/linux/ar71xx/Makefile
target/linux/brcm63xx/Makefile
target/linux/cns21xx/Makefile
target/linux/generic/patches-3.7/950-vm_exports.patch
target/linux/lantiq/Makefile
target/linux/malta/Makefile
target/linux/mpc83xx/Makefile
target/linux/mpc85xx/Makefile
target/linux/ppc40x/Makefile
target/linux/ppc44x/Makefile
target/linux/ramips/Makefile
target/linux/ramips/patches-3.7/a01-revert-ehci-port_power_off-removal.patch
target/linux/rb532/Makefile
target/linux/x86/alix2/target.mk
target/linux/x86/generic/target.mk
target/linux/x86/geos/target.mk

index f817bbb3e395b1acf4591a1bf0b98df2e9f6dd20..71669d0bc364a582074cabf71eba23d37f63d509 100644 (file)
@@ -8,8 +8,8 @@ endif
 ifeq ($(LINUX_VERSION),3.6.11)
   LINUX_KERNEL_MD5SUM:=3d602ad7f7984509c3e923a5ae90bc54
 endif
-ifeq ($(LINUX_VERSION),3.7.9)
-  LINUX_KERNEL_MD5SUM:=c19426374acfccfa7391fc90640240cb
+ifeq ($(LINUX_VERSION),3.7.10)
+  LINUX_KERNEL_MD5SUM:=09624c3702107076efcac5e1cd8a18ec
 endif
 ifeq ($(LINUX_VERSION),3.8)
   LINUX_KERNEL_MD5SUM:=1c738edfc54e7c65faeb90c436104e2f
index d04d652648cc77dd8b009d6c898936e5ef0ebb5f..47555c633609e00ce3c6fd9e75d0d7cb1645ba17 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 BOARD:=adm5120
 BOARDNAME:=Infineon/ADMtek ADM5120
-LINUX_VERSION:=3.7.9
+LINUX_VERSION:=3.7.10
 SUBTARGETS:=router_le router_be rb1xx
 INITRAMFS_EXTRA_FILES:=
 
index de6cd39b57961a4375e5e88bce5e3642d1d27815..cf75e81926865c422affe0096d1eab3dc670ccd2 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs jffs2 targz
 CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
 SUBTARGETS:=generic nand
 
-LINUX_VERSION:=3.7.9
+LINUX_VERSION:=3.7.10
 
 include $(INCLUDE_DIR)/target.mk
 
index 904366fd582c60c7cb8cd800d3c157fca2ece39b..41a8219b0334d21c9b37b81265bd3a76174d7ae3 100644 (file)
@@ -10,7 +10,7 @@ ARCH:=mips
 BOARD:=brcm63xx
 BOARDNAME:=Broadcom BCM63xx
 FEATURES:=squashfs jffs2 usb atm pci pcmcia
-LINUX_VERSION:=3.7.9
+LINUX_VERSION:=3.7.10
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
 include $(INCLUDE_DIR)/target.mk
index 975dc6deb41eb31ca1f76a0e1fd4cd1c0783b3f2..10d2df164b845bd07c631c3fa3f64aef0fa3b2a4 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Cavium Networks Econa CNS21xx
 FEATURES:=squashfs
 CFLAGS:=-Os -pipe -march=armv4 -mtune=fa526 -fno-caller-saves
 
-LINUX_VERSION:=3.7.9
+LINUX_VERSION:=3.7.10
 
 include $(INCLUDE_DIR)/target.mk
 
index 85126e4d60e08e906c4d6d75ae7311a99c071e85..d72f132d63377e28d4e391711a7528ea47fc62cc 100644 (file)
@@ -1,6 +1,6 @@
 --- a/mm/shmem.c
 +++ b/mm/shmem.c
-@@ -2775,6 +2775,15 @@ EXPORT_SYMBOL_GPL(shmem_truncate_range);
+@@ -2781,6 +2781,15 @@ EXPORT_SYMBOL_GPL(shmem_truncate_range);
  
  /* common code */
  
@@ -16,7 +16,7 @@
  /**
   * shmem_file_setup - get an unlinked file living in tmpfs
   * @name: name for dentry (to be seen in /proc/<pid>/maps
-@@ -2851,11 +2860,8 @@ int shmem_zero_setup(struct vm_area_stru
+@@ -2857,11 +2866,8 @@ int shmem_zero_setup(struct vm_area_stru
        file = shmem_file_setup("dev/zero", size, vma->vm_flags);
        if (IS_ERR(file))
                return PTR_ERR(file);
index d5e7148af2e88ee1dfdddd83fcc537fa39bb669c..ce0f0dc753df3ad88986a877548b46ae78ce0f82 100644 (file)
@@ -11,7 +11,7 @@ BOARDNAME:=Lantiq GPON/XWAY/SVIP
 FEATURES:=squashfs jffs2
 SUBTARGETS=xway ase falcon
 
-LINUX_VERSION:=3.7.9
+LINUX_VERSION:=3.7.10
 
 CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
 
index e343436b0ffa22bad677be029e7238b44dec974f..f6ce2d283e4a94fbae9f830501cc5ffe5696a984 100644 (file)
@@ -13,7 +13,7 @@ SUBTARGETS:=le be
 INITRAMFS_EXTRA_FILES:=
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.7.9
+LINUX_VERSION:=3.7.10
 
 DEVICE_TYPE:=developerboard
 
index 460db448d5efdcf45285080489fc76cdb0edad12..21f64339985cedfaf9de45eb6bd3dd23aea9a435 100644 (file)
@@ -13,7 +13,7 @@ CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=603e
 FEATURES:=squashfs targz
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.7.9
+LINUX_VERSION:=3.7.10
 
 include $(INCLUDE_DIR)/target.mk
 
index 0d2a5c11d0bfb70ef8a593b2836dfe738ec8bd36..262e1b9e3c7637f4d900f909d08f4a6b555f1f9f 100644 (file)
@@ -13,7 +13,7 @@ CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=8540
 FEATURES:=spe_fpu squashfs
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.7.9
+LINUX_VERSION:=3.7.10
 
 include $(INCLUDE_DIR)/target.mk
 
index 7368ffeaa74c6672a40338ab83e77451da8747a4..da697adc293633c4c7292bcd4eea341e97ff5ae0 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs
 CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=405
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.7.9
+LINUX_VERSION:=3.7.10
 
 include $(INCLUDE_DIR)/target.mk
 
index 9db22d499fe3f9965c951b57bc7d7799fe7a7cc0..eda8a8bde0a1bda47de33c1fb662a05fbf33d5bc 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs broken
 CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=440
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.7.9
+LINUX_VERSION:=3.7.10
 
 include $(INCLUDE_DIR)/target.mk
 
index b02c8016edd2257881793cb41401c68cfdb4814d..80cc960fa51cb2d24068f2b47adc183f6a199003 100644 (file)
@@ -13,7 +13,7 @@ SUBTARGETS:=rt288x rt305x rt3883
 CFLAGS:=-Os -pipe -fno-caller-saves -mno-branch-likely
 FEATURES:=squashfs
 
-LINUX_VERSION:=3.7.9
+LINUX_VERSION:=3.7.10
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES+=\
index ad2645a12d19ca5edeb925d7a4ccfc6c36614d44..c4d12f13d54518cfc32dbf2b94a7ece79da9aae5 100644 (file)
@@ -1,7 +1,7 @@
 reverted:
 --- a/arch/mips/ralink/rt3883/devices.c
 +++ b/arch/mips/ralink/rt3883/devices.c
-@@ -177,6 +177,7 @@
+@@ -177,6 +177,7 @@ static void rt3883_usb_power_off(struct
  }
  
  static struct usb_ehci_pdata rt3883_ehci_data = {
@@ -9,10 +9,9 @@ reverted:
        .power_on       = rt3883_usb_power_on,
        .power_off      = rt3883_usb_power_off,
  };
-reverted:
---- b/arch/mips/ralink/rt305x/devices.c
-+++ a/arch/mips/ralink/rt305x/devices.c
-@@ -356,6 +356,7 @@
+--- a/arch/mips/ralink/rt305x/devices.c
++++ b/arch/mips/ralink/rt305x/devices.c
+@@ -356,6 +356,7 @@ static void rt3352_usb_power_off(struct
  }
  
  static struct usb_ehci_pdata rt3352_ehci_data = {
index 28e1740c8684938a30bf7512cba936d51377b7bf..8524eb63e850f0cb62e42dadd75fc72565e2d458 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=rb532
 BOARDNAME:=Mikrotik RouterBoard 532
 FEATURES:=jffs2 pci targz broken
 
-LINUX_VERSION:=3.7.9
+LINUX_VERSION:=3.7.10
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += wpad-mini kmod-madwifi kmod-input-rb532
index d12ccc9ccf8361f328d2d87814494582dec33adc..573ca238eb3d4b8f2d7f4d1796510194aa0ed04d 100644 (file)
@@ -19,7 +19,7 @@ DEFAULT_PACKAGES += \
                        kmod-ledtrig-heartbeat kmod-ledtrig-gpio \
                        kmod-ledtrig-netdev \
                        kmod-cpu-msr hwclock wpad
-LINUX_VERSION:=3.7.9
+LINUX_VERSION:=3.7.10
 CS5535_MASK:=0x0b000042
 
 CFLAGS += -march=geode -Os -mmmx -m3dnow -fno-align-jumps -fno-align-functions \
index b7b4c63a4aaefa5aef4977b3baecf90a80b59c8a..99457401f2b2ba05a06b47b4e6558d1bdf371937 100644 (file)
@@ -1,6 +1,6 @@
 BOARDNAME:=Generic
 
-LINUX_VERSION:=3.7.9
+LINUX_VERSION:=3.7.10
 
 define Target/Description
        Build firmware images for x86 based boards
index 35c02843628360471a25296aca5bde6f540dd261..167c28745768419dd4b72264edd6d5af8732b7ee 100644 (file)
@@ -21,7 +21,7 @@ DEFAULT_PACKAGES += \
             kmod-cpu-msr \
             soloscli linux-atm br2684ctl ppp-mod-pppoa pppdump pppstats \
             hwclock wpad flashrom tc
-LINUX_VERSION:=3.7.9
+LINUX_VERSION:=3.7.10
 CS5535_MASK:=0x0E000048
 
 CFLAGS += -march=geode -Os -mmmx -m3dnow -fno-align-jumps -fno-align-functions \