php4: update to version 4.4.9
authorHauke Mehrtens <hauke@hauke-m.de>
Wed, 22 Dec 2010 01:50:46 +0000 (01:50 +0000)
committerHauke Mehrtens <hauke@hauke-m.de>
Wed, 22 Dec 2010 01:50:46 +0000 (01:50 +0000)
SVN-Revision: 24773

lang/php4/Makefile
lang/php4/patches/002-configure.patch
lang/php4/patches/003-dns_skipname.patch
lang/php4/patches/004-uts_domainname.patch
lang/php4/patches/100-compile_fix.patch

index 867ae9d8bd606cd4ced01603d3ad3bc96bb4563b..2ba1bf3abd33db84cb0ec9210e6fd3a16c32ab28 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=php4
-PKG_VERSION:=4.4.7
-PKG_RELEASE:=3
+PKG_VERSION:=4.4.9
+PKG_RELEASE:=1
 
 PKG_SOURCE:=php-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=http://fr.php.net/distributions/
-PKG_MD5SUM:=3f21b44d37a57ca3876d3aea713c700d
+PKG_SOURCE_URL:=http://www.php.net/distributions/
+PKG_MD5SUM:=2e3b2a0e27f10cb84fd00e5ecd7a1880
 PKG_BUILD_DIR:=$(BUILD_DIR)/php-$(PKG_VERSION)
 
 include $(INCLUDE_DIR)/package.mk
index 1197cdee3eb4b2f7da7cfb1b76e4f1cc191dfc5b..af47d5bf0070a4cf95bca6cf7b4889284b02c853 100644 (file)
@@ -1,6 +1,6 @@
---- a/configure.orig   2008-09-24 16:00:23.000000000 +0900
-+++ a/configure        2008-09-24 16:00:45.000000000 +0900
-@@ -12503,7 +12503,7 @@
+--- a/configure
++++ b/configure
+@@ -12503,7 +12503,7 @@ fi
      ac_libs=$LIBS
      LIBS="$LIBS -ldl"
      if test "$cross_compiling" = yes; then
@@ -9,7 +9,7 @@
  else
    cat > conftest.$ac_ext <<EOF
  #line 12510 "configure"
-@@ -14373,7 +14373,7 @@
+@@ -14373,7 +14373,7 @@ rm -f conftest*
  
                
                if test "$cross_compiling" = yes; then
@@ -18,7 +18,7 @@
  else
    cat > conftest.$ac_ext <<EOF
  #line 14380 "configure"
-@@ -15622,7 +15622,7 @@
+@@ -15622,7 +15622,7 @@ EOF
  if { (eval echo configure:15623: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
    rm -rf conftest*
    if test "$cross_compiling" = yes; then
@@ -27,7 +27,7 @@
  else
    cat > conftest.$ac_ext <<EOF
  #line 15629 "configure"
-@@ -16119,7 +16119,7 @@
+@@ -16119,7 +16119,7 @@ else
    rm -fr conftest*
    
    if test "$cross_compiling" = yes; then
  else
    cat > conftest.$ac_ext <<EOF
  #line 16126 "configure"
-@@ -43884,7 +43884,7 @@
+@@ -43891,7 +43891,7 @@ EOF
      echo $ac_n "checking if iconv supports errno""... $ac_c" 1>&6
- echo "configure:43886: checking if iconv supports errno" >&5
+ echo "configure:43893: checking if iconv supports errno" >&5
      if test "$cross_compiling" = yes; then
 -    { echo "configure: error: can not run test program while cross compiling" 1>&2; exit 1; }
 +    { echo "configure: error: can not run test program while cross compiling" 1>&2; }
  else
    cat > conftest.$ac_ext <<EOF
- #line 43891 "configure"
-@@ -46342,7 +46342,7 @@
+ #line 43898 "configure"
+@@ -46349,7 +46349,7 @@ rm -f conftest*
    old_LIBS=$LIBS
    LIBS="$TST_LIBS $LIBS"
    if test "$cross_compiling" = yes; then
@@ -53,8 +53,8 @@
 +    { echo "configure: error: can not run test program while cross compiling" 1>&2; }
  else
    cat > conftest.$ac_ext <<EOF
- #line 46349 "configure"
-@@ -46401,7 +46401,7 @@
+ #line 46356 "configure"
+@@ -46408,7 +46408,7 @@ echo "configure:46407: checking whether
    old_LIBS=$LIBS
    LIBS="$TST_LIBS $LIBS"
    if test "$cross_compiling" = yes; then
@@ -62,8 +62,8 @@
 +    { echo "configure: error: can not run test program while cross compiling" 1>&2; }
  else
    cat > conftest.$ac_ext <<EOF
- #line 46408 "configure"
-@@ -93621,7 +93621,7 @@
+ #line 46415 "configure"
+@@ -93628,7 +93628,7 @@ echo "configure:93628: checking for Sabl
      old_CPPFLAGS=$CPPFLAGS
      CPPFLAGS="$CPPFLAGS -I$XSLT_DIR/include"
      if test "$cross_compiling" = yes; then
@@ -71,8 +71,8 @@
 +    { echo "configure: error: can not run test program while cross compiling" 1>&2; }
  else
    cat > conftest.$ac_ext <<EOF
- #line 93628 "configure"
-@@ -102812,7 +102812,7 @@
+ #line 93635 "configure"
+@@ -102819,7 +102819,7 @@ variables_saved_for_relink="$variables_s
  link_all_deplibs=$link_all_deplibs
  
  # Compile-time system search path for libraries
index 6df37a28ad132a82580be4281c873d083486fc6d..02b16552453d4dfc8b206cbcce6c423f8a923c34 100644 (file)
@@ -1,6 +1,17 @@
---- php-4.3.9.orig/ext/standard/dns.c   2003-09-01 16:37:46.000000000 -0600
-+++ php-4.3.9/ext/standard/dns.c        2004-11-30 23:53:55.000000000 -0700
-@@ -207,7 +207,7 @@
+--- a/ext/standard/basic_functions.c
++++ b/ext/standard/basic_functions.c
+@@ -436,7 +436,7 @@ function_entry basic_functions[] = {
+       PHP_FE(gethostbyname,                                                                                                   NULL)
+       PHP_FE(gethostbynamel,                                                                                                  NULL)
+-#if HAVE_RES_SEARCH && !(defined(__BEOS__) || defined(PHP_WIN32) || defined(NETWARE))
++#if HAVE_RES_SEARCH && HAVE_DN_SKIPNAME && !(defined(__BEOS__)||defined(PHP_WIN32) || defined(NETWARE))
+       PHP_FE(checkdnsrr,                                                                                                              NULL)
+       PHP_FE(getmxrr,second_and_third_args_force_ref)
+ #endif
+--- a/ext/standard/dns.c
++++ b/ext/standard/dns.c
+@@ -207,7 +207,7 @@ static char *php_gethostbyname(char *nam
  }
  /* }}} */
  
@@ -9,15 +20,3 @@
  
  /* {{{ proto int checkdnsrr(string host [, string type])
     Check DNS records corresponding to a given Internet host name or IP address */
-
---- php-4.3.9.orig/ext/standard/basic_functions.c       2004-07-30 10:52:35.000000000 -0600
-+++ php-4.3.9/ext/standard/basic_functions.c    2004-11-30 23:56:42.000000000 -0700
-@@ -447,7 +447,7 @@
-       PHP_FE(gethostbyname,                                                                                                   NULL)
-       PHP_FE(gethostbynamel,                                                                                                  NULL)
-
--#if HAVE_RES_SEARCH && !(defined(__BEOS__) || defined(PHP_WIN32) || defined(NETWARE))
-+#if HAVE_RES_SEARCH && HAVE_DN_SKIPNAME && !(defined(__BEOS__)||defined(PHP_WIN32) || defined(NETWARE))
-       PHP_FE(checkdnsrr,                                                                                                              NULL)
-       PHP_FE(getmxrr,second_and_third_args_force_ref)
-#endif
\ No newline at end of file
index c7a312231f8d5aef26a5c9cb11e327c5d13d4b10..04aa5d7b09b7c219dfeb1e2126a9ecadc73de9dd 100644 (file)
@@ -1,7 +1,6 @@
-diff -urN php-4.3.11/ext/posix/posix.c php-4.3.11.new/ext/posix/posix.c
---- php-4.3.11/ext/posix/posix.c       2005-01-28 02:39:42.000000000 +0100
-+++ php-4.3.11.new/ext/posix/posix.c   2007-02-28 17:11:34.000000000 +0100
-@@ -533,7 +533,7 @@
+--- a/ext/posix/posix.c
++++ b/ext/posix/posix.c
+@@ -541,7 +541,7 @@ PHP_FUNCTION(posix_uname)
        add_assoc_string(return_value, "version",  u.version,  1);
        add_assoc_string(return_value, "machine",  u.machine,  1);
  #ifdef _GNU_SOURCE
index b62e21f1d4ea4efabac1a7b83714ceaced7a2ab7..35abdf87f11d51442946cd6592ad5829e11c24f4 100644 (file)
@@ -1,6 +1,6 @@
 --- a/Zend/zend_strtod.c
 +++ b/Zend/zend_strtod.c
-@@ -117,6 +117,7 @@
+@@ -117,6 +117,7 @@ typedef unsigned long int uint32_t;
  # endif
  #endif
  
@@ -8,7 +8,7 @@
  #ifdef WORDS_BIGENDIAN
  #define IEEE_BIG_ENDIAN
  #else
-@@ -141,6 +142,7 @@
+@@ -141,6 +142,7 @@ typedef unsigned long int uint32_t;
  #define uint32_t unsigned __int32
  #define IEEE_LITTLE_ENDIAN
  #endif