sane-backends: add missing dependency and ldflag
authorFelix Fietkau <nbd@openwrt.org>
Wed, 2 Sep 2009 22:39:29 +0000 (22:39 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Wed, 2 Sep 2009 22:39:29 +0000 (22:39 +0000)
SVN-Revision: 17483

utils/sane-backends/Makefile

index cef7efe74fafeeeb2bf616a5cca6ff4cc79d8111..1a520b296ffbae64caafbc943dfbaf2d6d589f94 100644 (file)
@@ -30,7 +30,7 @@ define Package/sane-backends
 $(call Package/sane-backends/Default)
   SECTION:=utils
   CATEGORY:=Utilities
-  DEPENDS:=+sane-libs
+  DEPENDS:=+sane-libs +libtiff
   TITLE+= (backends)
 endef
 
@@ -65,6 +65,10 @@ $(call Package/sane-backends/Default/description)
  This package contains the SANE frontends.
 endef
 
+TARGET_LDFLAGS += \
+       -Wl,-rpath-link $(STAGING_DIR)/usr/lib \
+       -Wl,-rpath-link $(PKG_BUILD_DIR)/backend/.libs
+
 CONFIGURE_ARGS+= \
        --enable-shared \
        --enable-static \