fix usage of flock - use the command mode instead of locking a file descriptor to...
authorFelix Fietkau <nbd@openwrt.org>
Sun, 31 Oct 2010 15:33:48 +0000 (15:33 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sun, 31 Oct 2010 15:33:48 +0000 (15:33 +0000)
SVN-Revision: 23743

rules.mk

index 007e5bc9b2f8176ddfcfbd0b880baf9b8ef9664a..3bd6073fb77dd01aa81ad5a4f91dc5f0bd5a4144 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -254,9 +254,10 @@ endef
 # $(2) => The lock name. If not given, the global lock will be used.
 # $(3) => The filedescriptor used for the lock. Defaults to 1023.
 define locked
-    ( $(STAGING_DIR_HOST)/bin/flock -x $(if $(3),$(3),1023) && \
-      $(1) \
-    ) $(if $(3),$(strip $(3)),1023)>$(TMP_DIR)/.$(if $(2),$(strip $(2)),global).flock
+       SHELL= \
+       $(STAGING_DIR_HOST)/bin/flock \
+               $(TMP_DIR)/.$(if $(2),$(strip $(2)),global).flock \
+               -c '$(subst ','\'',$(1))'
 endef
 
 # file extension