some minor fixes, cleanups, package build abstraction
authorFelix Fietkau <nbd@openwrt.org>
Fri, 28 Sep 2007 01:23:56 +0000 (01:23 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Fri, 28 Sep 2007 01:23:56 +0000 (01:23 +0000)
SVN-Revision: 9051

include/package-ipkg.mk
include/package.mk
include/prereq.mk
include/quilt.mk
include/target.mk

index f75c0a23f3d2019b745e27bc205abb00140c3853..16378a0f0e0143b4c191dd3727b46904dc3d0a8f 100644 (file)
@@ -23,7 +23,7 @@ define BuildIPKGVariable
 endef
 
 ifeq ($(DUMP),)
 endef
 
 ifeq ($(DUMP),)
-  define BuildIPKG
+  define BuildTarget/ipkg
     IPKG_$(1):=$(PACKAGE_DIR)/$(1)_$(VERSION)_$(PKGARCH).ipk
     IDIR_$(1):=$(PKG_BUILD_DIR)/ipkg/$(1)
     INFO_$(1):=$(IPKG_STATE_DIR)/info/$(1).list
     IPKG_$(1):=$(PACKAGE_DIR)/$(1)_$(VERSION)_$(PKGARCH).ipk
     IDIR_$(1):=$(PKG_BUILD_DIR)/ipkg/$(1)
     INFO_$(1):=$(IPKG_STATE_DIR)/info/$(1).list
@@ -92,9 +92,6 @@ ifeq ($(DUMP),)
     $(PKG_BUILD_DIR)/.version-$(1)_$(VERSION)_$(PKGARCH): $(STAMP_PREPARED)
        -@rm -f $(PKG_BUILD_DIR)/.version-$(1)_* 2>/dev/null
        @touch $$@
     $(PKG_BUILD_DIR)/.version-$(1)_$(VERSION)_$(PKGARCH): $(STAMP_PREPARED)
        -@rm -f $(PKG_BUILD_DIR)/.version-$(1)_* 2>/dev/null
        @touch $$@
-
-    $$(eval $$(call Build/DefaultTargets,$(1)))
-
   endef
 
   $(STAGING_DIR)/etc/ipkg.conf:
   endef
 
   $(STAGING_DIR)/etc/ipkg.conf:
index 43d0663f6038fdad36b4d27a903abfb4ddfe441a..9090455658c3f9b979972168c2ad7be531bb7324 100644 (file)
@@ -97,8 +97,15 @@ endif
   $(call shexport,Package/$(1)/description)
   $(call shexport,Package/$(1)/config)
 
   $(call shexport,Package/$(1)/description)
   $(call shexport,Package/$(1)/config)
 
-  $(Dumpinfo)
-  $(BuildIPKG)
+  $(if $(DUMP), \
+    $(Dumpinfo), \
+    $(foreach target, \
+      $(if $(Package/$(1)/targets),$(Package/$(1)/targets), \
+        $(if $(PKG_TARGETS),$(PKG_TARGETS), ipkg ) \
+      ), $(BuildTarget/$(target)) \
+    ) \
+  )
+  $(if $(DUMP),,$(call Build/DefaultTargets,$(1)))
 endef
 
 # prevent libtool from setting rpath when linking
 endef
 
 # prevent libtool from setting rpath when linking
index 8e5490ccff80161233cc76bede40f16f0e22d696..4a55c89ffcf9afd115aab72f64d4973c64bfc674 100644 (file)
@@ -5,6 +5,9 @@
 # See /LICENSE for more information.
 #
 
 # See /LICENSE for more information.
 #
 
+ifneq ($(__prereq_inc),1)
+__prereq_inc:=1
+
 prereq:
        if [ -f $(TMP_DIR)/.prereq-error ]; then \
                echo; \
 prereq:
        if [ -f $(TMP_DIR)/.prereq-error ]; then \
                echo; \
@@ -15,6 +18,7 @@ prereq:
        fi
 
 .SILENT: prereq
        fi
 
 .SILENT: prereq
+endif
 
 define Require
   export PREREQ_CHECK=1
 
 define Require
   export PREREQ_CHECK=1
index a7aac91c06cd230975655ef0869e258c46415d0d..4dce2a6d8ca2ef59312ab255d8c3100b1a2ce941 100644 (file)
@@ -5,6 +5,9 @@
 # See /LICENSE for more information.
 #
 
 # See /LICENSE for more information.
 #
 
+ifneq ($(__quilt_inc),1)
+__quilt_inc:=1
+
 ifeq ($(TARGET_BUILD),1)
   PKG_BUILD_DIR:=$(LINUX_DIR)
 endif
 ifeq ($(TARGET_BUILD),1)
   PKG_BUILD_DIR:=$(LINUX_DIR)
 endif
@@ -134,3 +137,4 @@ refresh: quilt-check
 update: quilt-check
        $(if $(KERNEL_BUILD),$(Quilt/Refresh/Kernel),$(Quilt/Refresh/Package))
 
 update: quilt-check
        $(if $(KERNEL_BUILD),$(Quilt/Refresh/Kernel),$(Quilt/Refresh/Package))
 
+endif
index c8eb76c254c03089e59347a0aa4e7f849caecc5f..1590b9109190027dd3a5e395f6407db83b83a677 100644 (file)
@@ -75,9 +75,11 @@ define Profile
   endif
 endef
 
   endif
 endef
 
--include $(PLATFORM_DIR)/profiles/*.mk
-ifneq ($(PLATFORM_DIR),$(PLATFORM_SUBDIR))
-  -include $(PLATFORM_SUBDIR)/profiles/*.mk
+ifeq ($(DUMP)$(if $(TARGET_BUILD),,1),)
+  -include $(PLATFORM_DIR)/profiles/*.mk
+  ifneq ($(PLATFORM_DIR),$(PLATFORM_SUBDIR))
+    -include $(PLATFORM_SUBDIR)/profiles/*.mk
+  endif
 endif
 
 $(eval $(call shexport,Target/Description))
 endif
 
 $(eval $(call shexport,Target/Description))