bmon: moved to github
authorNicolas Thill <nico@openwrt.org>
Thu, 29 Jan 2015 17:51:06 +0000 (17:51 +0000)
committerNicolas Thill <nico@openwrt.org>
Thu, 29 Jan 2015 17:51:06 +0000 (17:51 +0000)
https://github.com/openwrt/packages/commit/a8a3a02596786a35de04fdc39857162804034ae9

Signed-off-by: Nicolas Thill <nico@openwrt.org>
SVN-Revision: 44198

net/bmon/Makefile [deleted file]
net/bmon/patches/001-bugfixes.patch [deleted file]

diff --git a/net/bmon/Makefile b/net/bmon/Makefile
deleted file mode 100644 (file)
index bf0b53e..0000000
+++ /dev/null
@@ -1,49 +0,0 @@
-#
-# Copyright (C) 2007 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=bmon
-PKG_VERSION:=2.1.0
-PKG_RELEASE:=1
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://people.suug.ch/~tgr/bmon/files/
-PKG_MD5SUM:=3111a027907016c0902d67350c619df6
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/bmon
-  SECTION:=net
-  CATEGORY:=Network
-  DEPENDS:=+libncurses
-  TITLE:=bmon is a portable bandwidth monitor
-  URL:=http://people.suug.ch/~tgr/bmon/
-endef
-
-define Package/bmon/description
-       bmon is a portable bandwidth monitor
-       and rate estimator running on various
-       operating systems. It supports various
-       input methods for different architectures.
-endef
-
-CONFIGURE_ARGS += \
-       --disable-cnt-workaround \
-       --disable-dbi \
-       --disable-rrd \
-       --disable-asound \
-
-CONFIGURE_VARS += \
-       ac_cv_lib_nl_nl_connect=no \
-
-define Package/bmon/install
-       $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/bmon $(1)/usr/sbin/
-endef
-
-$(eval $(call BuildPackage,bmon))
diff --git a/net/bmon/patches/001-bugfixes.patch b/net/bmon/patches/001-bugfixes.patch
deleted file mode 100644 (file)
index fcb9306..0000000
+++ /dev/null
@@ -1,26 +0,0 @@
-Index: bmon-2.1.0/src/out_audio.c
-===================================================================
---- bmon-2.1.0.orig/src/out_audio.c    2007-11-20 17:25:54.000000000 +0100
-+++ bmon-2.1.0/src/out_audio.c 2007-11-20 17:25:54.000000000 +0100
-@@ -141,7 +141,7 @@
-       .om_draw = audio_draw,
-       .om_set_opts = audio_set_opts,
-       .om_probe = audio_probe,
--      .om_shutdown audio_shutdown,
-+      .om_shutdown = audio_shutdown,
- };
- static void __init audio_init(void)
-Index: bmon-2.1.0/src/out_xml_event.c
-===================================================================
---- bmon-2.1.0.orig/src/out_xml_event.c        2007-11-20 17:25:54.000000000 +0100
-+++ bmon-2.1.0/src/out_xml_event.c     2007-11-20 17:25:54.000000000 +0100
-@@ -127,7 +127,7 @@
-       .om_draw = xml_event_draw,
-       .om_set_opts = xml_event_set_opts,
-       .om_probe = xml_event_probe,
--      .om_shutdown xml_event_shutdown,
-+      .om_shutdown = xml_event_shutdown,
- };
- static void __init xml_event_init(void)