Add support for the 8250 UART module.
authorJo-Philipp Wich <jow@openwrt.org>
Sun, 18 Mar 2012 19:49:22 +0000 (19:49 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sun, 18 Mar 2012 19:49:22 +0000 (19:49 +0000)
It has been added at the end of other.mk as i couldn't find a better place
for it.

Signed-off-by: Christian Gagneraud <chris@techworks.ie>
SVN-Revision: 30989

package/kernel/modules/other.mk

index 23d558c955b2690ffcbdc32bc31829437a533950..b57d055d361cc23039e130d27f2d84c15227fbf6 100644 (file)
@@ -872,3 +872,21 @@ endef
 
 $(eval $(call KernelPackage,nandsim))
 
+define KernelPackage/serial-8250
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=8250 UARTs
+  KCONFIG:= CONFIG_SERIAL_8250 \
+       CONFIG_SERIAL_8250_NR_UARTS=16 \
+       CONFIG_SERIAL_8250_RUNTIME_UARTS=16 \
+       CONFIG_SERIAL_8250_EXTENDED=y \
+       CONFIG_SERIAL_8250_MANY_PORTS=y \
+       CONFIG_SERIAL_8250_SHARE_IRQ=y
+  FILES:=$(LINUX_DIR)/drivers/tty/serial/8250.ko
+endef
+
+define KernelPackage/serial-8250/description
+ Kernel module for 8250 UART based serial ports.
+endef
+
+$(eval $(call KernelPackage,serial-8250))
+