ramips: add support for Nexx WT1520
authorJohn Crispin <john@openwrt.org>
Fri, 10 Oct 2014 08:56:43 +0000 (08:56 +0000)
committerJohn Crispin <john@openwrt.org>
Fri, 10 Oct 2014 08:56:43 +0000 (08:56 +0000)
Signed-off-by: Roger Pueyo Centelles <roger.pueyo@guifi.net>
SVN-Revision: 42867

target/linux/ramips/base-files/etc/board.d/01_leds
target/linux/ramips/base-files/etc/board.d/02_network
target/linux/ramips/base-files/etc/diag.sh
target/linux/ramips/base-files/lib/ramips.sh
target/linux/ramips/base-files/lib/upgrade/platform.sh
target/linux/ramips/dts/WT1520.dts [new file with mode: 0644]
target/linux/ramips/image/Makefile
target/linux/ramips/rt305x/profiles/nexx.mk [new file with mode: 0644]

index b07c96af310744fa1b9a0f04e5f47e097eaadd33..26f384d3181e3f008ebe3b4a70f5a425f0597fe0 100755 (executable)
@@ -210,6 +210,9 @@ case $board in
                set_usb_led "wr8305rt:usb"
                set_wifi_led "wr8305rt:wifi"
                ;;
+       wt1520)
+               set_wifi_led "rt2800pci-phy0::radio"
+               ;;
        y1 |\
        y1s)
                ucidef_set_led_default "power" "power" "lenovo:blue:power" "1"
index c462fd8142e16d72c496c4445b651c8aae977ca2..7ecec5fd279db09a38250248b916160cc67f1e87 100755 (executable)
@@ -110,7 +110,8 @@ ramips_setup_interfaces()
        dir-615-h1 | \
        hlk-rm04 | \
        mzk-w300nh2 | \
-       mzk-750dhp)
+       mzk-750dhp | \
+       wt1520)
                ucidef_set_interfaces_lan_wan "eth0.1" "eth0.2"
                ucidef_add_switch "switch0" "1" "1"
                ucidef_add_switch_vlan "switch0" "1" "0 1 2 3 6t"
index 9752eb22ecc078de097e957b530562f77b919bea..aed7d6ab2e0e27639a2f80d798cdfa0565795738 100755 (executable)
@@ -167,6 +167,9 @@ get_status_led() {
        wnce2001)
                status_led="netgear:green:power"
                ;;
+       nexx-wt1520)
+               status_led="nexx-wt1520:white:power"
+               ;;
        mzk-w300nh2)
                status_led="mzkw300nh2:green:power"
                ;;
index 68ff509a4efb648c0b8412a30137ecca0d25934b..08c5dff020620033b617094dd3eb78fe23df46cb 100755 (executable)
@@ -181,6 +181,9 @@ ramips_board_detect() {
        *"NexAira BC2")
                name="bc2"
                ;;
+       *"Nexx WT1520")
+               name="wt1520"
+               ;;
        *"NW718")
                name="nw718"
                ;;
index 4aec78099a45f1faa110d2c574d8412cc001225d..52f3f0a3ee9c0510c614e1d9eb6ea11e54d7ba67 100755 (executable)
@@ -90,6 +90,7 @@ platform_check_image() {
        wnce2001 | \
        wli-tx4-ag300n | \
        whr-g300n |\
+       wt1520 |\
        ur-326n4g |\
        ur-336un |\
        wr512-3gn |\
diff --git a/target/linux/ramips/dts/WT1520.dts b/target/linux/ramips/dts/WT1520.dts
new file mode 100644 (file)
index 0000000..dc0ad32
--- /dev/null
@@ -0,0 +1,83 @@
+/dts-v1/;
+
+/include/ "rt5350.dtsi"
+
+/ {
+       compatible = "NEXXWT1520", "ralink,rt5350-soc";
+       model = "Nexx WT1520";
+
+       memory@0 {
+               device_type = "memory";
+               reg = <0x0 0x2000000>;
+       };
+
+       chosen {
+               bootargs = "console=ttyS1,57600";
+       };
+
+       palmbus@10000000 {
+               uart@500 {
+                       status = "okay";
+               };
+
+               spi@b00 {
+                       status = "okay";
+                       m25p80@0 {
+                               #address-cells = <1>;
+                               #size-cells = <1>;
+                               compatible = "w25q32";
+                               reg = <0 0>;
+                               linux,modalias = "m25p80", "s25fl064k";
+                               spi-max-frequency = <10000000>;
+
+                               partition@0 {
+                                       label = "u-boot";
+                                       reg = <0x0 0x30000>;
+                                       read-only;
+                               };
+
+                               partition@30000 {
+                                       label = "u-boot-env";
+                                       reg = <0x30000 0x10000>;
+                                       read-only;
+                               };
+
+                               factory: partition@40000 {
+                                       label = "factory";
+                                       reg = <0x40000 0x10000>;
+                                       read-only;
+                               };
+
+                               partition@50000 {
+                                       label = "firmware";
+                                       reg = <0x50000 0x3b0000>;
+                               };
+                       };
+               };
+       };
+
+       pinctrl {
+               state_default: pinctrl0 {
+                       gpio {
+                               ralink,group = "jtag";
+                               ralink,function = "gpio";
+                       };
+               };
+       };
+
+       ethernet@10100000 {
+               mtd-mac-address = <&factory 0x4>;
+       };
+
+       wmac@10180000 {
+               ralink,mtd-eeprom = <&factory 0>;
+       };
+
+       ehci@101c0000 {
+               status = "okay";
+       };
+
+       ohci@101c1000 {
+               status = "okay";
+       };
+};
index c365d9dbb59e354457da921eebc28714206092e9..93554489a6b638c2c3f6d2aecb548cadb9f67a34 100644 (file)
@@ -550,6 +550,13 @@ Image/Build/Profile/WNCE2001=$(call BuildFirmware/WNCE2001/$(1),$(1),wnce2001,WN
 
 Image/Build/Profile/WR512-3GN=$(call BuildFirmware/DefaultDualSize/$(1),$(1),wr512-3ng,WR512-3GN)
 
+define BuildFirmware/WT1520/initramfs
+       $(call BuildFirmware/OF/initramfs,$(1),$(2),$(3),$(4))
+endef
+BuildFirmware/WT1520/squashfs=$(call BuildFirmware/Default4M/squashfs,$(1),$(2),$(3),$(4))
+
+Image/Build/Profile/WT1520=$(call BuildFirmware/WT1520/$(1),$(1),wt1520,WT1520,WT1520)
+
 Image/Build/Profile/UR-326N4G=$(call BuildFirmware/Default4M/$(1),$(1),ur-326n4g,UR-326N4G)
 
 Image/Build/Profile/UR-336UN=$(call BuildFirmware/Default8M/$(1),$(1),ur-336un,UR-336UN)
@@ -638,6 +645,7 @@ define Image/Build/Profile/Default
        $(call Image/Build/Profile/WNCE2001,$(1))
        $(call Image/Build/Profile/WR512-3GN,$(1))
        $(call Image/Build/Profile/WR6202,$(1))
+       $(call Image/Build/Profile/WT1520,$(1))
        $(call Image/Build/Profile/X5,$(1))
        $(call Image/Build/Profile/X8,$(1))
        $(call Image/Build/Profile/XDXRN502J,$(1))
diff --git a/target/linux/ramips/rt305x/profiles/nexx.mk b/target/linux/ramips/rt305x/profiles/nexx.mk
new file mode 100644 (file)
index 0000000..eaef4c1
--- /dev/null
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/WT1520
+       NAME:=Nexx WT1520
+       PACKAGES:=kmod-usb2
+endef
+
+define Profile/WT1520/Description
+       Package set for WT1520
+endef
+
+$(eval $(call Profile,WT1520))