merge gdb package from trunk to replace the gdbserver package (fixes #5884)
authorFelix Fietkau <nbd@openwrt.org>
Thu, 24 Sep 2009 18:48:13 +0000 (18:48 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Thu, 24 Sep 2009 18:48:13 +0000 (18:48 +0000)
SVN-Revision: 17698

package/gdb/Makefile [new file with mode: 0644]
package/gdbserver/Makefile [deleted file]

diff --git a/package/gdb/Makefile b/package/gdb/Makefile
new file mode 100644 (file)
index 0000000..113bc78
--- /dev/null
@@ -0,0 +1,66 @@
+# Copyright (C) 2006-2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=gdb
+PKG_VERSION:=6.8
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=@GNU/gdb
+PKG_MD5SUM:=c9da266b884fb8fa54df786dfaadbc7a
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/gdb
+  SECTION:=utils
+  CATEGORY:=Utilities
+  DEPENDS:=+libreadline +libncurses
+  TITLE:=GNU Debugger
+endef
+
+define Package/gdbserver
+  SECTION:=utils
+  CATEGORY:=Utilities
+  TITLE:=Remote server for GNU Debugger
+endef
+
+define Package/gdb/description
+ GNU debugger
+endef
+
+define Package/gdbserver/description
+ GDBSERVER is a program that allows you to run GDB on a different machine 
+ than the one which is running the program being debugged.
+endef
+
+CONFIGURE_ARGS+= \
+       --with-system-readline
+
+CONFIGURE_VARS+= \
+       ac_cv_search_tgetent="$(TARGET_LDFLAGS) -lncurses -lreadline"
+
+define Build/Compile
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               CPPFLAGS="$(TARGET_CPPFLAGS)" \
+               all install-gdb
+endef
+
+define Package/gdb/install     
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/gdb $(1)/usr/bin/
+endef
+
+define Package/gdbserver/install       
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/gdbserver $(1)/usr/bin/
+endef
+
+$(eval $(call BuildPackage,gdb))
+$(eval $(call BuildPackage,gdbserver))
+
diff --git a/package/gdbserver/Makefile b/package/gdbserver/Makefile
deleted file mode 100644 (file)
index e8fb2ee..0000000
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright (C) 2006 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-# $Id$
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=gdbserver
-PKG_VERSION:=6.3
-PKG_RELEASE:=1
-
-GDB_DIR:=$(BUILD_DIR_TOOLCHAIN)/gdb-$(PKG_VERSION)
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/gdbserver
-  SECTION:=utils
-  CATEGORY:=Utilities
-  DEPENDS:=@GDB
-  TITLE:=Remote Server for the GNU Debugger
-endef
-
-define Package/gdbserver/description
- GDBSERVER is a program that allows you to run GDB on a different machine 
- than the one which is running the program being debugged.
-endef
-
-define Build/Configure
-       (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status}; \
-               $(TARGET_CONFIGURE_OPTS) \
-               CFLAGS="$(TARGET_CFLAGS)" \
-               $(GDB_DIR)/gdb/gdbserver/configure \
-                 --target=$(GNU_TARGET_NAME) \
-                 --host=$(GNU_TARGET_NAME) \
-                 --build=$(GNU_HOST_NAME) \
-                 --program-prefix="" \
-                 --program-suffix="" \
-                 --prefix=/usr \
-                 --exec-prefix=/usr \
-                 --bindir=/usr/bin \
-                 --sbindir=/usr/sbin \
-                 --libexecdir=/usr/lib \
-                 --sysconfdir=/etc \
-                 --datadir=/usr/share \
-                 --localstatedir=/var \
-                 --mandir=/usr/man \
-                 --infodir=/usr/info \
-                 $(DISABLE_NLS) \
-                 $(DISABLE_LARGEFILE) \
-       );
-endef
-
-define Build/Compile
-       rm -rf $(PKG_INSTALL_DIR)
-       mkdir -p $(PKG_INSTALL_DIR)
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               install
-endef
-
-define Package/gdbserver/install       
-       $(INSTALL_DIR) $(1)/usr/bin
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/gdbserver $(1)/usr/bin/
-endef
-
-$(eval $(call BuildPackage,gdbserver))
-