[packages] php5: add gettext module
authorMichael Heimpold <mhei@heimpold.de>
Fri, 13 May 2011 19:02:24 +0000 (19:02 +0000)
committerMichael Heimpold <mhei@heimpold.de>
Fri, 13 May 2011 19:02:24 +0000 (19:02 +0000)
SVN-Revision: 26887

lang/php5/Makefile

index 59fcdcf2c3f9f4313d7fb295db4a65f2ada172ef..4b4a00b1bcb758c6be3984e8ed663a6ddcc9cde1 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=php
 PKG_VERSION:=5.3.6
 
 PKG_NAME:=php
 PKG_VERSION:=5.3.6
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://www.php.net/distributions/
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://www.php.net/distributions/
@@ -25,7 +25,7 @@ PHP5_MODULES = \
        dom \
        exif \
        ftp \
        dom \
        exif \
        ftp \
-       gd gmp \
+       gettext gd gmp \
        hash \
        iconv \
        json \
        hash \
        iconv \
        json \
@@ -129,7 +129,6 @@ CONFIGURE_ARGS+= \
        --enable-magic-quotes \
        --disable-short-tags \
        \
        --enable-magic-quotes \
        --disable-short-tags \
        \
-       --without-gettext \
        --with-zlib="$(STAGING_DIR)/usr" \
          --with-zlib-dir="$(STAGING_DIR)/usr" \
        --with-pcre-regex="$(STAGING_DIR)/usr" \
        --with-zlib="$(STAGING_DIR)/usr" \
          --with-zlib-dir="$(STAGING_DIR)/usr" \
        --with-pcre-regex="$(STAGING_DIR)/usr" \
@@ -189,6 +188,12 @@ else
   CONFIGURE_ARGS+= --disable-fileinfo
 endif
 
   CONFIGURE_ARGS+= --disable-fileinfo
 endif
 
+ifneq ($(CONFIG_PACKAGE_php5-mod-gettext),)
+  CONFIGURE_ARGS+= --with-gettext=shared,"$(STAGING_DIR)/usr/lib/libintl-full"
+else
+  CONFIGURE_ARGS+= --without-gettext
+endif
+
 ifneq ($(CONFIG_PACKAGE_php5-mod-dom),)
   CONFIGURE_ARGS+= --enable-dom=shared
 else
 ifneq ($(CONFIG_PACKAGE_php5-mod-dom),)
   CONFIGURE_ARGS+= --enable-dom=shared
 else
@@ -479,6 +484,7 @@ $(eval $(call BuildModule,fileinfo,Fileinfo,+libmagic))
 $(eval $(call BuildModule,dom,DOM,@PHP5_LIBXML +libxml2))
 $(eval $(call BuildModule,exif,EXIF))
 $(eval $(call BuildModule,ftp,FTP))
 $(eval $(call BuildModule,dom,DOM,@PHP5_LIBXML +libxml2))
 $(eval $(call BuildModule,exif,EXIF))
 $(eval $(call BuildModule,ftp,FTP))
+$(eval $(call BuildModule,gettext,Gettext,+libintl-full))
 $(eval $(call BuildModule,gd,GD graphics,+libgd))
 $(eval $(call BuildModule,gmp,GMP,+libgmp))
 $(eval $(call BuildModule,hash,Hash))
 $(eval $(call BuildModule,gd,GD graphics,+libgd))
 $(eval $(call BuildModule,gmp,GMP,+libgmp))
 $(eval $(call BuildModule,hash,Hash))